Outlook Mobile Access users cannot access their mailboxes on a heavily-loaded Exchange Server 2003 computer (842119)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition, when used with:
    • Microsoft Windows 2000 Server
    • Microsoft Windows 2000 Advanced Server

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

On a heavily-loaded Microsoft Exchange Server 2003 computer, users in your organization may not be able to access their mailboxes by using Microsoft Outlook Mobile Access. In this scenario, an Outlook Mobile Access user may receive an error message that is similar to the following:
A system error has occurred, please see your system administrator.
Additionally, all the following events may appear in the Application log on the Exchange Server 2003 computer:

Event 1Event Type: Error
Event Source: MSExchangeOMA
Event Category: (1000)
Event ID: 1507
Date: date
Time: time
User: N/A
Computer: servername
Description: An unknown error occurred while processing the current request: Exception of type Microsoft.Exchange.OMA.DataProviderInterface.ProviderException was thrown.

Stack trace:
at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
at System.Web.SessionState.SessionStateModule.CompleteAcquireState()
at System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
at System.Web.AsyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
Inner Error: Exception has been thrown by the target of an invocation

Stack trace:
at System.Reflection.RuntimeConstructorInfo.InternalInvoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault)
at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
Inner Error: Exception of type System.OutOfMemoryException was thrown.
Event 2Event Type: Error
Event Source: MSExchangeOMA
Event Category: (1000)
Event ID: 1503
Date: date
Time: time
User: N/A
Computer: servername
Description: An unknown error occurred while processing the current request: Exception of type System.OutOfMemoryException was thrown. Event 3Event Type: Error
Event Source: MSExchangeOMA
Event Category: (1000)
Event ID: 1503
Date: date
Time: time
User: N/A
Computer: servername
Description: An unknown error occurred while processing the current request: Exception of type System.OutOfMemoryException was thrown.

CAUSE

This problem may occur if Exchange Server 2003 is running on a Microsoft Windows 2000-based computer. In this scenario, virtual memory fragmentation may occur if Exchange Server 2003 is under a heavy load. You may experience this problem during stress-testing of your Exchange Server environment.

RESOLUTION

To resolve this problem, follow these steps.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Obtain and install the hotfix that is described in the following Microsoft Knowledge Base article:

    820745 Failfast occurs when you experience an "out of memory" condition

  2. Configure the following registry entry with a value of 1:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework

    Value name: GCFailFastOnOOM
    Value type: REG_DWORD
    Value data: 1

After you configure this registry entry, if you experience an out-of-memory condition on your Exchange Server computer, an event that contains the following description is logged:Failed to allocate numberOfbytes bytes with numberOfbytes bytes in use and numberOfbytes free bytes. Process will be TerminatedHowever, in this scenario, a new process is automatically started on the next user request. No administrative action is required.

WORKAROUND

To work around this problem, restart the World Wide Web Publishing service on the Exchange Server computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:11/4/2005
Keywords:kbpending kbtshoot kbprb kberrmsg kbBug KB842119 kbAudITPRO