Intermittent "You Cannot Eject Your Computer" error message when you click Eject PC in Windows XP (842058)
The information in this article applies to:
- Microsoft Windows XP Professional
- Microsoft Windows XP Home Edition
SYMPTOMS
When you click the Eject PC button that is displayed when your Microsoft Windows XP-based portable computer is connected to a docking station or to a port replicator, you may occasionally receive the following error message:
You cannot eject your computer because one of the devices in the docking station, installed device, cannot be stopped because a program is still assessing it.
Note In this error message, installed device is a hardware component that is connected to the docking station or to the port replicator. The installed device may be an ECP printer port (LPT1), a printer, a Pocket PC device, or any other universal serial bus (USB) device.
CAUSE
The Eject PC command disconnects devices from the docking station. When you click Eject PC, the Plug and Play manager issues a notification that informs programs and drivers to close their open handles. After the programs and drivers respond, PnP then examines the handle count on all devices that are attached to the docking station. If the result is nonzero, the Plug and Play manager assumes that a program still has the handle open on the device and therefore denies the eject request.RESOLUTIONTo resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base: 322389 How to obtain the latest Windows XP service pack STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.
Modification Type: | Major | Last Reviewed: | 8/26/2004 |
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Keywords: | kbtshoot ATdownload kbWinXPsp2fix kberrmsg kbpending kbbug KB842058 kbAudEndUser |
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