You may receive an "Access denied" error message when you try to restore a Message Queuing back-up file (842041)



The information in this article applies to:

  • Microsoft Message Queuing 2.0

SYMPTOMS

When you try to restore a Message Queuing back-up file by using the Mqbkup.exe utility, the restore may fail, and you may receive the following error message:
Access denied

CAUSE

This problem occurs when you are logged on to the computer without Administrator permissions.

RESOLUTION

To resolve the problem, log on to the computer with Administrator permissions.

MORE INFORMATION

Steps to reproduce the problem

To do this, follow these steps:
  1. Log on to the computer without Administrator permissions.
  2. Try to restore a Message Queuing back-up file by using the Mqbkup.exe utility.

    When you restore a back-up file by using the Mqbkup.exe utility, the Mqbkup.exe utility first tries to delete all files from the directory and then to copy the back-up files to the empty directory. The Mqbkup.exe utility cannot delete all files from the directory without Administrator permissions. Therefore, you receive the error message that is mentioned in the "Symptoms" section.

REFERENCES

For additional information about backing up and restoring messages, visit following Microsoft Web site:

Modification Type:MajorLast Reviewed:4/20/2005
Keywords:kbtshoot kbSysAdmin kblogin kbBackup kbprb KB842041 kbAudDeveloper