Performance counter logs show a very high initial value in Windows Server 2003 (841960)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you view a performance counter log that is in comma-delimited or tab-delimited format on a Microsoft Windows 2003-based server, the initial value is very high. For example, the initial value may be 99.99.

CAUSE

This problem occurs because only one raw sample is available when the performance counter starts, and the counter requires two raw samples to calculate the correct value. The Performance Data Helper feature incorrectly uses the one raw sample to process the counter value.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 32-bit editions
   Date         Time   Version       Size    File name
   -------------------------------------------------------------------
   06-May-2004  20:27  5.2.3790.170  282,112  Pdh.dll
   21-Apr-2004  16:35                    271  Branches.inf
   06-May-2004  20:28                    354  Updatebr.inf
   06-May-2004  20:29                  5,629  Update_rtmqfe.inf
Windows Server 2003, 64-Bit Enterprise Edition
   Date         Time   Version       Size     File name	      Platform
   -------------------------------------------------------------------
   06-May-2004  20:23  5.2.3790.170  747,520  Pdh.dll            IA-64
   06-May-2004  20:27  5.2.3790.170  282,112  Wpdh.dll             x86
   21-Apr-2004  16:35                    271  Branches.inf
   06-May-2004  20:29                    354  Updatebr.inf
   06-May-2004  20:29                  5,879  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB841960 kbAudITPRO