Software metering information is not added to the database in Systems Management Server 2003 (841901)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

Software metering information is not added to the database, or the information is added slowly. Additionally, a backlog of files accumulates in the \SMS\Inboxes\Swmproc.box folder on your Microsoft Systems Management Server (SMS) 2003 site server, although the Software Metering component continuously tries to process .sum files from client computers.

CAUSE

This problem may occur when the Software Metering component on the site server tries to process a summary record from a client that no longer exists in the database.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   25-Dec-2003  09:40  2.50.2726.133  249,856  Swmproc.dll
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

Hotfix installation instructions

  1. Create a shared folder in a location that is accessible to your SMS site servers.
  2. Copy the SMS2003-RTM-KB841901-X86-ENU.exe hotfix file to the new shared folder.
  3. On each SMS primary and secondary site server in your environment, log on by using an account that has administrative credentials.
  4. Close the SMS Administrator window if it is open.
  5. On each primary and secondary site server, connect to the shared folder that contains the hotfix, double-click the SMS2003-RTM-KB841901-X86-ENU.exe file, and then follow the instructions in the wizard.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

WORKAROUND

To work around this problem, manually delete the old .sum and .sur files in the \SMS\inboxes\swmproc.box folder on the site server.

MORE INFORMATION

When this problem occurs, the following error is logged in the Swmproc.log file:
CSoftwareMeteringProcessor::ProcessSummarizedUsageData - ERROR: Unable to import summary data from file, missing a machine.
This hotfix creates a configurable registry key that lets you to configure how many times the Software Metering Processor tries to process a file when the client no longer exists in the database. By default, this value is set to 18. After you apply the hotfix, you can change the value at the following registry location:

HKLM\Software\Microsoft\SMS\Components\SMS_SOFTWARE_METERING_PROCESSOR Summary File Retry Count

The new value may be any value from 1 to 25. After you change this value, the Software Metering Processor logs the following information:
Maximum summary file retry count changed to: value
The Software Metering Processor checks for changes when you start your computer, every hour, and when the site control file is changed.

Note You will not lose any data when the .sum or .sur files are deleted. Additionally, any other .sum files will not be synchronously processed because .sum files are processed in order.

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:5/29/2006
Keywords:kbQFE kbHotfixServer kbServer KbClientServer kbsmsMeter kbSMSTopazFix kbPerformance kbfix kbBug KB841901 kbAudITPRO