Cannot create a scheduled task in Windows XP (841846)



The information in this article applies to:

  • Microsoft Windows XP Professional

SYMPTOMS

When you try to create a scheduled task by using the Scheduled Task Wizard in Microsoft Windows XP, the wizard stops responding. If you open Task Manager, and then click the Applications tab, the Scheduled Task Wizard is listed as Not Responding. If you click the Processes tab in Windows Task Manager, you find that the Explorer.exe process consumes a high percentage of CPU cycles. The process typically consumes between 96 and 99 percent of the CPU cycles.

Note To open Task Manager, press CTRL+ALT+DEL.

CAUSE

This problem may occur if the following conditions are true:
  • You are logged on to the computer as a member of the local Users group. For example, you are logged on under Computer_Name\Users, where Computer_Name is the name of your computer.
  • Permissions for the Users and Everyone groups have been removed from the NTFS file system security Access Control List (ACL) for the Start Menu folder in the All Users profile. These permissions have also been removed for all subfolders in the Start Menu folder in the All Users profile.
For example, this problem typically occurs if permissions for the Users and Everyone groups have been removed from the NTFS security ACL for the Administrative Tools folder in the All Users profile.

The problem occurs because when the Scheduled Task Wizard builds the list of available tasks, the wizard scans several locations, including the Administrative Tools folder in the All Users profile. If these locations do not have the correct permissions, the Scheduled Task Wizard may stop responding.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows XP 64-Bit Edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-May-2004  21:11  5.1.2600.1536     635,392  Mstask.dll       IA-64
   11-Apr-2004  01:55  5.1.2600.1515      25,600  Mstinit.exe      IA-64
   28-May-2004  21:11  5.1.2600.1515     576,000  Schedsvc.dll     IA-64
   11-Apr-2004  03:33  5.1.2600.1515     592,896  Xpsp2res.dll     IA-64
   11-Apr-2004  04:04  5.1.2600.1515     593,408  Wxpsp2res.dll
Windows XP
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-May-2004  21:07  5.1.2600.1536     259,584  Mstask.dll       
   11-Apr-2004  02:46  5.1.2600.1515      10,752  Mstinit.exe      
   28-May-2004  21:07  5.1.2600.1515     172,544  Schedsvc.dll     
   11-Apr-2004  04:04  5.1.2600.1515     593,408  Xpsp2res.dll

WORKAROUND

To work around this problem, restore the default permissions to the Start Menu folder or to the subfolder that has had permissions removed. For example, to restore permissions for the Administrative Tools folder in the All Users profile:
  1. Log on to the computer as an administrator.
  2. Start Windows Explorer, and then open the following folder:

    C:\Documents and Settings\All Users\Start Menu\Programs\

  3. Right-click the Administrative Tools folder, and then click Properties.
  4. Click the Security tab, and then click Advanced.
  5. Click to select the Inherit from parent the permission entries that apply to child objects. Include these with entries explicitly defined here check box, and then click Apply.
  6. Click to select the Replace permission entries on all child objects with entries shown here that apply to child objects check box, and then click Apply.

    Caution If you select the Replace permission entries on all child objects with entries shown here that apply to child objects check box, all subfolders and files will have all their permissions reset to be the same as the parent object's permissions. After you have clicked Apply or OK, you cannot undo this operation by clearing the check box.
  7. Click OK, and then log on to the computer as a member of the Users group to verify that you can create a Scheduled Task.
Note If the problem still occurs, you may have to repeat these steps for other subfolders of the Start Menu folder in the All Users profile. To verify that the Users and Everyone groups have permissions for a folder, right-click the folder, and then click Properties. Click the Security tab, and then verify that the Users and Everyone groups appear in the Group or user names list. By default, the following objects are listed:
  • Administrators (Computer_Name\Administrators)
  • Everyone
  • Power Users (Computer_Name\Power Users)
  • SYSTEM
  • Users (Computer_Name\Users)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbtshoot kbWinXPpreSP2fix kbfix kbbug KB841846 kbAudEndUser