The System Restore service does not work correctly in Windows XP (841568)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

You may experience one or more of the following issues in the System Restore service:
  • In System Properties, the System Restore tab is not present.

    Note To view System Properties, right-click My Computer, and then click Properties.
  • In Services, the System Restore service is listed as stopped.
  • If you try to manually start the System Restore service, you may receive the following error message:
    FOLDER IS NOT EMPTY

CAUSE

This issue may occur if there is a problem with the System Volume Information folder on your computer.

Note By default, the System Volume Information folder (drive:\System Volume Information) is hidden.

RESOLUTION

To resolve this issue, rename the System Volume Information folder, and then restart your computer. To do this, you must use an account with administrator permissions. If you have more than one hard disk drive on your computer, follow these steps on one hard disk drive at a time. To rename the System Volume Information folder, follow these steps:
  1. Configure the View hidden files and folders setting in Folder Options if it is not configured. To do this, follow these steps:
    1. Right-click Start, click Explore, click Tools, and then click Folder Options.
    2. Click the View tab.
    3. In the Advanced settings box, click Show hidden files and folders, and then click OK.
  2. Locate the root of a hard disk drive. Work in reverse alphabetical order by drive letter. For example, if you have three hard drives on your computer with the drive letters "C", "E", and "F", follow these steps on drive F, on drive E, and then on drive C.
  3. Right-click the System Volume Information folder, and then click Rename.
  4. Type a new similar name for the folder, and then press ENTER. For example, type System Volume Information2, and then press ENTER.
  5. Restart your computer, and then test to determine if the issue is resolved.
  6. If the issue is not resolved, repeat steps 2-5 for the next drive on your computer in reverse alphabetical order by drive letter.

Modification Type:MajorLast Reviewed:12/16/2004
Keywords:kbtshoot kbprb KB841568