You cannot establish a VPN connection by using a dial-up connection on a Windows XP-based computer (841566)



The information in this article applies to:

  • Microsoft Windows XP Professional

SYMPTOMS

Consider the following scenario:
  • You try to establish a virtual private network (VPN) connection by using a dial-up connection on a Microsoft Windows XP-based computer.
  • The Windows XP-based computer uses a Cisco VPN client.
  • The Windows XP-based computer uses a security solution that implements an intermediate driver by using a custom filter class. For example, the computer may use a security solution such as Senforce Enterprise Mobile Security Manager.
In this scenario, the VPN client cannot establish the connection and stops responding.

CAUSE

This problem occurs because the binding that connects the TCP/IP protocol, the Cisco VPN driver, and the dial-up networking stack (NDISWAN) is not handled correctly in this scenario.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows XP, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ndis.sys5.1.2600.1577168,19220-Jul-200401:53x86SP1SP1QFE
Nwlnkipx.sys5.1.2600.157584,86411-Jul-200419:01x86SP1SP1QFE
Windows XP, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ndis.sys5.1.2600.1577579,32816-Jul-200412:16IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp1fix kbBug kbfix kbpubtypekc KB841566 kbAudITPRO kbAudEndUser