You cannot review all the tracked changes in a Word 2003 document (841539)



The information in this article applies to:

  • Microsoft Office Word 2003

For a Microsoft Word 2002 version of this article, see 837108.
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you use the Next button to step through the tracked changes that are in a Microsoft Office Word 2003 document, you may not be able to review all the tracked changes, and you receive the following error message

Do you want to continue searching from the beginning of the document?


If you try to step through the tracked changes programmatically, you may receive the following error message:

Run-time error '5852': Requested object is not available.

CAUSE

This problem may occur if the following conditions are true:
  • A paragraph formatting change was made inside a table.
  • A formatting change was made to an end-of-row marker in a table.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest Office 2003 service pack, you do not have to install the hotfix.

Service pack information

This problem is corrected in Office 2003 Service Pack 2.

To resolve this problem, obtain the latest service pack for Office 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

870924 How to obtain the latest service pack for Office 2003

After you install the service pack, follow the steps that are listed in the "More Information" section of the article to set the AlternateRevisionStepThrough registry value and to activate the hotfix.

Hotfix information

How to obtain the hotfix

This issue is fixed in the Word 2003 post-Service Pack 1 Hotfix Package that is dated August 20, 2004. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

838899 Description of the Word 2003 post-Service Pack 1 hotfix package: August 20, 2004



After you install this hotfix, follow the steps that are listed in the "More Information" section of this article to set the AlternateRevisionStepThrough registry key and to activate the hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Office 2003 Service Pack 2.

MORE INFORMATION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To activate this hotfix, follow these steps:
  1. Quit Word 2003.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate, and then click to select the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options

  5. After you select the key that is specified in step 4, point to New on the Edit menu, and then click DWORD Value.
  6. Type AlternateRevisionStepThrough, and then press ENTER.
  7. Right-click AlternateRevisionStepThrough, and then click Modify.
  8. In the Value data box, type 1, and then click OK.
  9. On the File menu, click Exit to quit Registry Editor.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbRegistry kbOffice2003SP2fix kbOffice2003preSP2fix kbfix kbbug kbQFE KB841539 kbAudITPRO kbAudEndUser