You experience excessive call time-outs when the Speech Engine Service (SES) is stopped and the Speech Server is load balanced in Speech Server 2004 (841392)



The information in this article applies to:

  • Microsoft Speech Server 2004 Enterprise Edition
  • Microsoft Speech Server 2004 Standard Edition
  • Microsoft Speech Server 2004 R2 Enterprise
  • Microsoft Speech Server R2 Standard

SYMPTOMS

In Microsoft Speech Server 2004, you experience excessive call time-outs when the following conditions are true:
  • It takes a longer time than expected to decline open speech sessions.
  • The Speech Application Deployment Service (SADS) is still running.
  • The Speech Engine Service (SES) is stopped.
  • The Speech Server is Network Load Balanced or Hardware Load Balanced.

CAUSE

This issue occurs because it takes a long time to discover when the SES is stopped. When the SES is running in a load-balanced configuration, load balancers cannot instantly determine whether a TCP port has closed on a local host. Because the SADS is still running, the SADS continues to answer calls even when the SES is not available.

WORKAROUND

To work around this issue, use both of the following methods:
  • Use the discovery feature of a load balancer to use a shorter discovery time.
  • When SES is stopped, the administrator must stop Microsoft Internet Information Services (IIS) or disable the SADS in IIS.
Note These methods will reduce the number of calls that experience time-outs. However, you may still experience some call time-outs.

MORE INFORMATION

For more information about Network Load Balancing, visit the following Microsoft Web site:

REFERENCES

For more technical information about Microsoft Speech Server, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:7/6/2005
Keywords:kbprb kbBug KB841392 kbAudDeveloper