BUG: A "no" answer is falsely recognized when you first answer "yes" to the question "Any extension" in Speech Software Development Kit (841388)



The information in this article applies to:

  • Microsoft Speech Software Development Kit (SDK) 1.0

SYMPTOMS

Consider the following scenario. In Microsoft Speech Software Development Kit (SDK) 1.0, you use a phone control to obtain a phone number. You answer "yes" to the question, "Any extension?" Then, you answer "no" to the same question after you deny the extension. In this scenario, you may experience the following behavior:
  • When you use text emulation to say "no", you receive the following reply:

    "I didn't understand you, any extension?"

  • When you say "no" by using voice, Speech SDK falsely recognizes "no" as the number nine. The engine may not always recognize "no" as the number nine. Something else in the grammar is just as likely to be recognized.
Note This issue also occurs when you use the ZipCode control.

CAUSE

This issue occurs because the question and answer flow has a prompt select function to change the prompt and has a grammar select function to change the grammar. The grammar select function deactivates the "yes" or "no" answer when an extension is required. When you deny the extension, the prompt select function does not reactivate the "yes" or "no" answer.

WORKAROUND

To work around this issue, follow these steps:
  1. Include the following Microsoft JScript function in a separate file or include the following JScript function inside the .aspx page where the phone control is located:
    function kbfunction()
    {
    if( Phone1.SaidHasExtention && siExtension.IsEmpty() )
    {	
                    SpeechCommon.needPostback = true;
    }
    } 
    Note Phone1 is the ID of the control, and siExtension is the semantic item that receives the extension number.
  2. Add the function to the onClientComplete event of the phone control by using code that is similar to the following code example:
    <speech:phone id="Phone1" runat="server" onclientcomplete="kbfunction" .../>

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:6/30/2005
Keywords:kbpending kbtshoot kbbug KB841388 kbAudDeveloper