"Unable to open Web project" error message or "Web server conflict" error message when you try to open a Web project (841296)



The information in this article applies to:

  • Microsoft Visual Basic .NET (2003)
  • Microsoft Visual Basic .NET (2002)

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you try to open a Microsoft ASP.NET Web project in Microsoft Visual Basic .NET, you may receive one the following error messages:
Unable to open Web project 'ProjectName'. The file path 'FilePath' does not correspond to the URL 'ProjectURL'. The two need to map to the same server location.
Note ProjectName is a placeholder for the name of the ASP.NET Web project. FilePath is a placeholder for the file path of the ASP.NET Web project. ProjectURL is a placeholder for the URL of the ASP.NET Web project.
FrontPage has detected a Web server conflict on Port 80, which has server extensions for the FrontPage Personal Web Server but is running a Microsoft-IIS/Version server. FrontPage requires that you install the FrontPage Server Extensions on this new server before running it. Would you like to see help on how to do this?
Note Version is a placeholder for the version of Microsoft Internet Information Services (IIS) that is installed on your computer.

CAUSE

Microsoft FrontPage Personal Web Server was installed on your computer and then removed from your computer. However, the Windows registry still contains a registry entry that specifies that FrontPage Personal Web Server is using port 80. Internet Information Services (IIS) tries to use port 80 as the Transmission Control Protocol (TCP) port for the default Web site. However, because the registry entry still specifies that FrontPage Personal Web Server is using port 80, a Web server conflict exists on port 80.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve the problem, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. In Registry Editor, locate the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\Ports\Port 80

  3. Right-click the Port 80 subkey, and then click Delete. The Confirm Key Delete dialog box appears.
  4. Click Yes to delete the subkey.
  5. Exit Registry Editor.
  6. Click Start, click Run, type inetmgr, and then click OK.

    In Microsoft Windows Server 2003, the Internet Information Services (IIS) Manager window opens. In Microsoft Windows 2000 or Microsoft Windows XP, the Internet Information Services window opens.
  7. In the left pane, right-click Default Web Site, and then click Properties. The Default Web Site Properties dialog box appears.
  8. In the TCP port box, type 80, and then click OK.
  9. Start Visual Basic .NET.
  10. Try to open an ASP.NET Web project. The behavior that is mentioned in the "Symptoms" section does not occur.

STATUS

This behavior is by design.

REFERENCES

For more information, visit the following Microsoft Developer Network (MSDN) Web site:

Modification Type:MinorLast Reviewed:2/9/2006
Keywords:kbvs2005swept kbvs2005doesnotapply kbtshoot kbIDEProject kbRegistry kberrmsg kbprb KB841296 kbAudDeveloper