"Out of Memory" error message when you print in Works (841220)



The information in this article applies to:

  • Microsoft Works 7.0
  • Microsoft Works Suite 2004
  • Microsoft Works Suite 2003

SYMPTOMS

When you try to print or when you try to preview a spreadsheet or a database file in Microsoft Works, you may receive an error message that is similar to the following:
Microsoft Works Out of Memory

CAUSE

This problem may occur if there is a problem with the printer driver that is installed on your computer.

RESOLUTION

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
To resolve this problem, use the following methods in the order that they appear in.

Method 1: Install a different printer driver

Contact the manufacturer of your printer to inquire about how to obtain and install the most recent version of the printer driver for your printer.

For information about how to contact about how to contact the manufacturer of your printer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

Method 2: Configure the printer as the default printer

Configure the printer driver that you have installed as the default printer. To do this, follow these steps:
  1. Click Start, and then click Printer and Faxes.
  2. Right-click the printer that you want to set as the default printer, and then click Set as Default Printer.
  3. Click File, and then click Close.
  4. Start Works, and then print the spreadsheet or the database file.

Method 3: Install an emulation printer driver

If the problem persists after you install the most recent version of the printer driver for your printer, install an emulation printer driver. An emulation printer driver is a driver that imitates the functionality of a different printer driver. For example, you may be able to resolve this issue if you install the driver for the Hewlett-Packard DeskJet 550C printer or for the Hewlett-Packard LaserJet II printer. To do this, follow these steps if the printer is connected directly to the computer:
  1. Click Start, and then click Printers and Faxes.
  2. Double-click Add Printer.
  3. Click Next, and then click Local printer attached to this computer.
  4. In the Use the following port box, select the port that you want to use.

    If the printer is connected directly to the computer, the port is typically LPT1 (Recommended Printer Port).
  5. Under Manufacturer, click the manufacturer of the printer driver that you want to use as the emulation driver. For example, if you are installing Hewlett Packard 550c, click HP DeskJet 550c.
  6. Under Printers, click the model of the printer that you want to use as the emulation driver, and then click Next. Select HP. In Drivers, select HP DeskJet 550c.
  7. In the Printer name box, type a name for the printer, click Yes to set the printer as the default printer, and then click Next.
  8. Click the appropriate option for sharing the printer, and then click Next.
  9. Click No, and then click Next.
  10. Click Finish.

    Note If you are using a USB printer, go to step 12.
  11. Start Works, and then try to print the spreadsheet or the database file.
  12. Open Control Panel.
  13. Open Printers and Faxes.
  14. Right-click HP 550c, and then click Properties.
  15. Click Ports.
  16. Click USB001 Virtual Printer port for USB.
  17. Click Apply, and then click OK.
  18. Start Works, and then try to print the spreadsheet or the database file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was corrected in Microsoft Works 8 and in Microsoft Works Suite 2005.

MORE INFORMATION

If you install an emulation printer driver and configure it as the default printer, you may want to set the original printer driver as the default printer for when you print from other programs. To configure another printer driver as the default printer, follow these steps:
  1. Click Start, and then click Printers and Faxes.
  2. Right-click the printer driver that you want to use as the default printer, and then click Set as Default Printer
To delete an emulation printer driver, follow these steps:
  1. Click Start, and then click Printers and Faxes.
  2. Right-click the printer driver that you want to delete, and then click Delete.

Modification Type:MinorLast Reviewed:3/31/2006
Keywords:kberrmsg kbprb KB841220