You cannot successfully mount a tape drive on a Windows Server 2003-based server (841187)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you try to use the Removable Storage service to manage a tape drive on your Microsoft Windows Server 2003-based server, you may not be able to successfully mount the drive. In this scenario, you receive one of the following error messages:
Removable Storage:

Unable to read from or write to the database.

There is a problem with the Removable Storage Service. Please restart the service.
Removable Storage

The object identifier does not represent a valid object.

This snap-in's display may be inconsistent with the Removable Storage Service. If the problem persists please restart the snap-in.
If you view the properties for the tape drive by using the Removable Storage service, the tape drive may have two tabs that have the same name:

Device Information

Additionally, each Device Information tab may display a different firmware revision number.

CAUSE

This problem occurs when you update the firmware for the tape drive. After the drive has been updated, Removable Storage may not be able to obtain the device serial number for the tape drive. In this scenario, Removable Storage uses the device instance name. But because the device has been updated, the device instance name has been changed. Removable Storage then creates a new device and a new drive, but it associates this information with the old device library entry. Therefore, an association is created in that entry between the two drives. This association may prevent the tape drive from being mounted correctly.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   03-May-2004  17:06  5.2.3790.169      177,152  Ntmsdba.dll      
   03-May-2004  17:06  5.2.3790.169      444,928  Ntmssvc.dll      
   22-Apr-2004  01:46  5.2.3790.165       46,592  Ws03res.dll      

Windows Server 2003 64-Bit Edition

   Date         Time   Version            Size    File name    Platform
   --------------------------------------------------------------------
   03-May-2004  17:00  5.2.3790.169      452,096  Ntmsdba.dll  IA-64
   03-May-2004  17:00  5.2.3790.169    1,273,344  Ntmssvc.dll  IA-64
   22-Apr-2004  01:18  5.2.3790.165       46,080  Ws03res.dll  IA-64
   22-Apr-2004  01:46  5.2.3790.165       46,592  Wws03res.dll x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbQFE kbHotfixServer KB841187 kbAudITPRO