You cannot access encrypted files after you log on by using a password that was changed programmatically in Windows Server 2003 (841105)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition

SYMPTOMS

When you log on to a Microsoft Windows Server 2003-based computer that has a password that was changed programmatically, you may not be able to access encrypted files. Additionally, you may receive an error message that states that access is denied.

CAUSE

This problem may occur in either of the following scenarios:
  • The password for the local user account was changed by using the Active Directory Service Interfaces (ADSI) ChangePassword method in a Visual Basic script.

    In this scenario, the Lsasrv.dll file does not correctly parse the local computer name that is contained in the Visual Basic script.
  • The password for the local user account was changed by using "\\ComputerName" as the first parameter of the NetUserChangePassword function.

    In this scenario, the computer name is not parsed correctly because the program calls the NetUserChangePassword function with a non-NULL value that has a "\\" prefix. For example "\\NETBIOSLOCALMACHINENAME." If the value that is passed to the NetUserChangePassword function is NULL or NETBIOSLOCALMACHINENAME, this problem does not occur.

WORKAROUND

To work around the problem that was caused by the second scenario in the "Cause" section, reverse the password change that you made. Then, perform the password change again by using a NULL value for the NetUserChangePassword function. To do this, follow these steps:
  1. Call the NetUserChangePassword function with the following parameters to change the password back to the previous password:

    NetUserChangePassword(\\NETBIOSLOCALMACHINENAME, ...)

  2. Call the NetUserChangePassword function again with a NULL value to change the password again.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003 32-bit versions
   Date         Time   Version            Size  File name
   ---------------------------------------------------------
   19-Nov-2004  01:45  5.2.3790.212     64,000  Eventlog.dll
   19-Nov-2004  01:45  5.2.3790.233    801,792  Lsasrv.dll
   18-Nov-2004  19:56  5.2.3790.233     13,312  Lsass.exe
Windows Server 2003 64-bit versions
   Date         Time   Version            Size  File name
   ---------------------------------------------------------
   18-Nov-2004  12:21  5.2.3790.212    167,936  Eventlog.dll
   18-Nov-2004  12:21  5.2.3790.233  2,039,296  Lsasrv.dll
   18-Nov-2004  06:20  5.2.3790.233     15,360  Lsass.exe
Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB841105 kbAudITPRO