You receive a "Stop 0x000000D1" error message on your Windows 2000-based computer (840890)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

On your Microsoft Windows 2000-based computer, you receive the following Stop error message:
STOP: 0x000000D1 (0x00000000, 0x00000002, 0x00000000, 0x00000000)
DRIVER_IRQL_NOT_LESS_OR_EQUAL

CAUSE

This problem occurs because of a regression that was introduced in the post-Windows 2000 Service Pack 4 hotfix that is described in the following Microsoft Knowledge Base article:

818635 Your portable computer cannot renew its IP address from a DHCP server after you remove the computer from a docking station

The Stop error occurs in the Tcpip.sys driver if the Net Table Entry (NTE) list is not correctly cleaned up after the client receives a "destination host unreachable" error message from Internet Control Message Protocol (ICMP).

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Windows 2000 Service Pack 3 or later.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   19-Jun-2003  20:05  5.0.2195.6687     120,240  Afd.sys
   19-Jun-2003  20:05  5.0.2195.6602     108,816  Msafd.dll        
   19-May-2004  19:45  5.0.2195.6930     318,544  Tcpip.sys
   19-Jun-2003  20:05  5.0.2195.6655      16,240  Tdi.sys
   19-Jun-2003  20:05  5.0.2195.6601      17,680  Wshtcpip.dll   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named and about other terms for software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWin2000preSP5fix KB840890 kbAudITPRO