You receive a "device is not ready" error message when you try to list the contents of a floppy disk after you resume the computer from standby in Windows 2000 SP3 or in Windows 2000 SP4 (840883)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Professional SP3

SYMPTOMS

When you try to list the contents of a floppy disk on a Microsoft Windows 2000 Service Pack 3 (SP3)-based computer or on a Windows 2000 Service Pack 4 (SP4)-based computer, you receive the following error message:
The device is not ready.

CAUSE

This problem occurs in the following scenario:
  1. You resume a Windows 2000 SP3-based computer or a Windows 2000 SP4-based computer from standby.
  2. You insert a floppy disk into the floppy disk drive.
  3. You open a command prompt.
  4. At the command prompt, you type the following command and then press ENTER:

    DIR A:

This problem occurs if the floppy disk controller is not enabled when you resume the computer from standby.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Windows 2000 Service Pack 3 (SP3) or Service Pack 4 (SP4).

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
---------------------------------------------------------
22-Jun-2004  18:32  5.0.2195.6942      26,320  Fdc.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWin2000preSP5fix KB840883 kbAudITPRO kbAudEndUser