Event ID 14163 is logged and you cannot receive inbound e-mail through your ISA Server 2000 computer (840682)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000

SYMPTOMS

On your Microsoft Internet Security and Acceleration (ISA) Server 2000 computer, inbound Simple Mail Transfer Protocol (SMTP) e-mail no longer works correctly. The following event is logged to the application event log:Event Type: Warning
Event Source: Microsoft Firewall
Event ID: 14163
Description:
Server publishing rule [rule_name] that maps ip_address :25 TCP to ip_address:25 for protocol [SMTP Server] failed because the port on the external interface is being used by another application. The Firewall service failed to bind socket for the server on the firewall since another process is using the same port. Check for any other process using the same port and terminate if necessary. You may experience this symptom after you restart your ISA Server computer.

CAUSE

This behavior may occur if both the following conditions are true:
  • You have a server publishing rule on your ISA Server 2000 computer that is configured to publish your internal mail server.
  • The SMTP service is installed and running on your ISA Server 2000 computer.
When the SMTP service starts, it may block the internal mail server publishing rule from using the SMTP port.

RESOLUTION

To resolve this behavior, use either of the following methods:

Method one

Stop the SMTP service, set it to manual startup, and then restart your ISA Server computer. To do this, follow these steps:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  2. Right-click Simple Mail Transport Protocol (SMTP), and then click Properties.
  3. On the General tab, click Stop.
  4. In the Startup type list, click Manual, and then click OK.
  5. Restart your ISA Server computer.

Method two

Remove the SMTP service from your ISA Server computer if the SMTP service is not required on the server. To do this, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Click Add/Remove Programs.
  3. Click Add/Remove Windows Components.
  4. Click Internet Information Services (IIS), and then click Details.

    Note Do not click to clear the check box that is next to Internet Information Services (IIS).
  5. Click to clear the SMTP Service check box, and then click OK.
  6. Click Next, and then click Finish.

Modification Type:MajorLast Reviewed:5/17/2004
Keywords:kbprb KB840682 kbAudITPRO