Group Policy application fails on a computer that is running Windows 2000, Windows XP Service Pack 1, or Windows XP Service Pack 2 (840669)



The information in this article applies to:

  • Microsoft Windows 2000 Professional
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP2

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you start your Microsoft Windows 2000-based, Windows XP Service Pack 1 (SP1)-based, or Windows XP Service Pack 2 (SP2)-based computer on a wired network or on a wireless network that has 802.11 authentication, Group Policy may not apply as expected, or the computer may not join the Active Directory directory service.

When you view the log files in Event Viewer, you see the following entries:
  • Event ID: 1054
    Source: Userenv
    Type: Error
    Description: Windows cannot obtain the domain controller name for your computer network. (The specified domain either does not exist or exist or could not be contacted). Group Policy processing aborted. Data: (unavailable)
  • Event ID: 1000
    Source: UserInit
    Type: Error
    Description: Could not execute the following script AdminPassword.bat. The system cannot find the file specified. Data: (unavailable)
Additionally, the following entries are logged in the Userenv.log log file:
  • USERENV(52c.18c) 16:36:14:597 ProcessGPOs: The DC for domain <domain> is not available at startup. Retrying.
  • USERENV(52c.18c) 16:36:14:597 RetryDCContactAtMachineStartup: Enter.
  • USERENV(52c.18c) 16:36:14:597 RetryDCContactAtMachineStartup: Failed to query GpNetworkStartTimeoutPolicyValue with 2, exit.
  • USERENV(52c.18c) 16:36:14:597 RetryDCContactAtMachineStartup: Exit with status 1355.
  • USERENV(52c.18c) 16:36:14:597 ProcessGPOs: The DC for domain <domain> is not available after retries.
  • USERENV(52c.18c) 16:36:14:597 ProcessGPOs: The DC for domain <domain> is not available. aborting
  • USERENV(52c.18c) 16:36:14:757 ProcessGPOs: No WMI logging done in this policy cycle.
  • USERENV(52c.18c) 16:36:14:757 ProcessGPOs: Processing failed with error 1355.

CAUSE

This problem may occur if the Group Policy engine or Active Directory times out while it waits for the network to start. A race condition may occur between the TCP/IP protocol and the network adaptor driver when they try to register with the Microsoft Network Driver Interface Specification (NDIS). If the TCP/IP protocol registers with NDIS before the network adaptor driver, for a short time it prompts higher user mode networking components that network connectivity is not available. During this short time, the Group Policy startup script cannot be downloaded.

This problem is more likely to occur on fast networks that use 1 gigahertz (GHz) network adaptors or in teaming environments where the network takes several additional cycles to negotiate link speed.

RESOLUTION

Windows 2000

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 update rollup that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version             Size  File name
   ----------------------------------------------------------
   17-Jun-2004  23:05  5.0.2195.6951     46,352  Basesrv.dll
   21-Sep-2003  00:45  5.0.2195.6824    236,304  Cmd.exe
   17-Jun-2004  23:05  5.0.2195.6945    231,184  Gdi32.dll
   17-Jun-2004  23:05  5.0.2195.6946    712,464  Kernel32.dll
   24-Mar-2004  02:17  5.0.2195.6898     37,136  Mf3216.dll
   24-Mar-2004  02:17  5.0.2195.6824     54,544  Mpr.dll
   17-Jun-2004  23:05  5.0.2195.6928    335,120  Msgina.dll
   24-Mar-2004  02:17  5.0.2195.6892     90,264  Rdpwd.sys
   06-Jan-2005  04:29  5.0.2195.7017  6,278,656  Sp3res.dll
   24-Mar-2004  02:17  5.0.2195.6897    403,216  User32.dll
   18-Jan-2005  05:44  5.0.2195.7021    396,048  Userenv.dll
   10-Aug-2004  03:51  5.0.2195.6966  1,632,624  Win32k.sys
   24-Aug-2004  22:59  5.0.2195.6970    182,544  Winlogon.exe
   17-Jun-2004  23:05  5.0.2195.6946    244,496  Winsrv.dll
   17-Jun-2004  23:05  5.0.2195.6946    712,464  Kernel32.dll
   10-Aug-2004  03:51  5.0.2195.6966  1,632,624  Win32k.sys
   17-Jun-2004  23:05  5.0.2195.6946    244,496  Winsrv.dll
After you install this hotfix, you must add the GpNetworkStartTimeoutPolicyValue registry entry. This entry defines the number of seconds to wait before you try to run the Group Policy startup script again. To find the value that will work for your configuration, define a decimal value of 60, and then increase the value until the problem is resolved. To add the registry entry and to define the value, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Expand the following subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

  3. Right-click Winlogon, point to New, and then click DWORD Value.
  4. To name the new entry, type GpNetworkStartTimeoutPolicyValue, and then press ENTER.
  5. Right-click GpNetworkStartTimeoutPolicyValue, and then click Modify.
  6. Under Base, click Decimal.
  7. In the Value data box, type 60, and then click OK.
  8. Quit Registry Editor, and then restart your computer.
  9. If the Group Policy startup script does not run, increase the value of the GpNetworkStartTimeoutPolicyValue registry entry.

Windows XP Service Pack 1

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows XP, 64-bit versions
   Date         Time   Version        Size       File name     Platform
   --------------------------------------------------------------------
   04-Jun-2004  05:52  5.1.2600.1534  1,718,272  Userenv.dll   IA-64
   04-Jun-2004  05:44  5.1.2600.1534    672,256  Wuserenv.dll    x86
Windows XP, 32-bit versions
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   04-Jun-2004  05:44  5.1.2600.1534  672,256  Userenv.dll
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must add the GpNetworkStartTimeoutPolicyValue registry entry. This entry defines the number of seconds to wait before trying to run the Group Policy startup script again. To find the value that will work for your configuration, define a decimal value of 60, and then increase the value until the problem is resolved. To add the registry entry and to define the value, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Expand the following subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

  3. Right-click Winlogon, point to New, and then click DWORD Value.
  4. To name the new entry, type GpNetworkStartTimeoutPolicyValue, and then press ENTER.
  5. Right-click GpNetworkStartTimeoutPolicyValue, and then click Modify.
  6. Under Base, click Decimal.
  7. In the Value data box, type 60, and then click OK.
  8. Close Registry Editor, and then restart your computer.
  9. If the Group Policy startup script does not run, increase the value of the GpNetworkStartTimeoutPolicyValue registry entry.

Windows XP Service Pack 2

After you apply Windows XP Service Pack 2, you must add the GpNetworkStartTimeoutPolicyValue registry entry. This entry defines the number of seconds to wait before trying to run the Group Policy startup script again. To find the value that will work for your configuration, define a decimal value of 60, and then increase the value until the problem is resolved. To add the registry entry and to define the value, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Expand the following subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

  3. Right-click Winlogon, point to New, and then click DWORD Value.
  4. To name the new entry, type GpNetworkStartTimeoutPolicyValue, and then press ENTER.
  5. Right-click GpNetworkStartTimeoutPolicyValue, and then click Modify.
  6. Under Base, click Decimal.
  7. In the Value data box, type 60, and then click OK.
  8. Close Registry Editor, and then restart your computer.
  9. If the Group Policy startup script does not run, increase the value of the GpNetworkStartTimeoutPolicyValue registry entry.

Creating a Group Policy network start timeout policy

The GpNetworkStartTimeoutPolicyValue policy timeout can be specified in the registry in two locations:
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current Version\Winlogon
  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System
You can do this by adding a DWORD value of GpNetworkStartTimeoutPolicyValue with a number of seconds between 30 and 600.

For the first connection, there is no GpNetworkStartTimeoutPolicyValue DWORD value under the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System subkey. Therefore, the value under the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current Version\Winlogon subkey is useful to specify the time-out. However, if you manually set GpNetworkStartTimeoutPolicyValue for the first connection, the GpNetworkStartTimeoutPolicyValue value under the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current Version\Winlogon subkey is always ignored. The GpNetworkStartTimeoutPolicyValue value under the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System subkey is used only for the first connection. After the first connection, the exact time that the connection takes is stored as GpNetworkStartTimeoutPolicyValue under the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System subkey. During subsequent connections, the time-out value is always equal to the GpNetworkStartTimeoutPolicyValue value under the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System subkey.

The value specified should be of sufficient duration to make sure that the connection is made. During the timeout period, Windows examines the connection status every two seconds and continues with system startup as soon as the connection is confirmed. Therefore, setting the value larger than the minimum value of 30 is recommended. However, be advised that if the system is legitimately disconnected, Windows will stall for the whole timeout period.

Note Examples of the system being legitimately disconnected include the network cable being disconnected or if the server is offline.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Note This problem is known to occur on the Toshiba Dynabook laptop that uses an Intel network adapter. The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

REFERENCES

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:8/8/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug KB840669 kbAudITPRO