OEM extensions to SMS cannot submit status messages in Systems Management Server 2003 (840660)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

You develop an extension to the Microsoft Systems Management Server (SMS) 2003 Advanced Client that submits a status message to a management point. But the status message that you submit does not appear when you view all the messages for the object that you submitted a status message for.

CAUSE

This problem occurs when a management point receives a status message from an SMS 2003 Advanced Client that is not in Windows Management Instrumentation (WMI) binary format.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

885643 How to obtain the latest Systems Management Server 2003 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires SMS 2003 without a service pack.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   25-Dec-2003  11:45  2.50.2726.134     296,960  Ccmcore.dll      
   25-Dec-2003  11:45                  6,453,760  Mp.msi    
  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you apply this hotfix, management points will accept status messages that are submitted in XML format or in WMI binary format.

For additional information about how to obtain the latest Systems Management Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

885643 How to obtain the latest Systems Management Server 2003 service pack



For additional information about SMS 2003 SP1 status messages, visit the following Microsoft Web site:

For additional information about SMS 2003 software updates, click the following article number to view the article in the Microsoft Knowledge Base:

870652 Systems Management Server 2003 software updates now use Update.exe


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMSReporting kbSMSClients kbSMSMP kbwinservperf kbMgmtServices kbBug kbfix KB840660 kbAudITPRO