The DNS search order is reversed on the DHCP client in Windows 2000 and Windows XP (840629)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional

Notice

SYMPTOMS

When you use a dial-up or a virtual private network (VPN) connection to connect to a Routing and Remote Access server, the list of Domain Name System (DNS) servers is stored on the client computer in reverse order.

For example, when you connect to the Routing and Remote Access server, Dynamic Host Configuration Protocol (DHCP) sends the DNS IP addresses in the preferred order:
10.200.200.200
10.201.201.201
However, if you view the TCP/IP protocol properties on the client computer, the DNS IP addresses appear in the following order:
10.201.201.201
10.200.200.200

CAUSE

This problem occurs because the Remote Access Point-to-Point Protocol (PPP) component (Rasppp.dll) writes the DNS IP addresses to the client registry in reverse order.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Apr-2004  18:52  5.0.2195.6920     198,928  Rasppp.dll 

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows XP 32-bit edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Apr-2004  23:59  5.1.2600.1522     194,048  Rasppp.dll 
Windows XP 64-bit edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Apr-2004  21:13  5.1.2600.1522     578,560  Rasppp.dll       IA-64
   29-Apr-2004  20:59  5.1.2600.1522     194,048  Wrasppp.dll      x86

MORE INFORMATION

For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


For additional information about how to use DHCP with Routing and Remote Access, click the following article number to view the article in the Microsoft Knowledge Base:

232703 How to use DHCP to provide Routing and Remote Access clients with additional DHCP

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer ATdownload kbWinXPsp2fix kbDHCP kbClient kbnetwork kbWinXPpreSP2fix kbWin2000SP5fix kbRemoting kbfix kbBug KB840629 kbAudITPRO kbAudEndUser