You receive a "Failed to enlist transaction" error message when a transaction is processed in a Commerce Server 2002 Web site (840573)



The information in this article applies to:

  • Microsoft Commerce Server 2002

SYMPTOMS

When a transaction is processed in a Microsoft Commerce Server 2002 Web site, you may receive the following error message:

Failed to enlist a transaction

CAUSE

This problem may occur when the Microsoft Distributed Transaction Coordinator (DTC) services on the computer where the transaction originated are not synchronized with the DTC services on a remote computer that is configured to process the transaction.

RESOLUTION

To resolve this problem, you must restart both the Microsoft SQL Server services and the DTC services on both computers.

Note Make sure that you restart the DTC services on both computers first before you restart the SQL Server services.

To do this, follow these steps:
  1. Use the SQL Service Manager to stop SQL Server services on both computers.
  2. Use the Services tool in the Microsoft Management Console to stop the Distributed Transaction Coordinator services on both computers.
  3. Use the Services tool to start the Distributed Transaction Coordinator services on both computers.
  4. Use the SQL Service Manager to start SQL services on both computers.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Microsoft Commerce Server 2002, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:6/8/2004
Keywords:kbprb KB840573 kbAudDeveloper kbAudEndUser kbAudITPRO