Compressed .exe files that are served from IIS are truncated when you are running Internet Explorer 6 (840387)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0

SYMPTOMS

When you download and open an executable file, the file may be truncated if all the following conditions are true:
  • The file is being served from a server that is running Microsoft Internet Information Server (IIS) 6.
  • The file is dynamically compressed by the Gzip compression utility.
However, if you open the file and then click Save As instead of Open on the File menu, Internet Explorer 6 correctly saves the file.

Note An executable file uses the .exe file name extension.

CAUSE

This problem occurs because Internet Explorer 6 does not correctly open an executable file that has been compressed by the Gzip utility and that is stored on an IIS server.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size       File name
   ------------------------------------------
   15-Apr-2004  18:59    589,824  Wininet.dll
   21-Apr-2004  15:33  1,344,512  Shdocvw.dll
   15-Apr-2004  18:58    485,888  Urlmon.dll
   15-Apr-2004  18:56  2,799,104  Mshtml.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbBug kbfix KB840387 kbAudEndUser