Roaming profiles are not unloaded on a Windows Server 2003-based computer that is running Terminal Services (840378)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When a user logs off a Windows Server 2003-based computer that is running Terminal Services, Index.dat files may not be deleted on the server. This problem occurs even though the "Delete cached roaming profiles" Group Policy setting is enabled.

CAUSE

This problem may occur if the following conditions are true:
  • A user logs off a Windows Server 2003-based computer that is running Terminal Services after the administrator installs Microsoft Internet Explorer 6 or Internet Explorer 6 Service Pack 1 (SP1) on the server.
  • The "Important URLs & Favorites and Links" Windows Server 2003 Group Policy setting is enabled.
Cached profile folders are created but are not deleted because three Index.dat files cannot be deleted in three different subfolders. Therefore, every time that a user logs on and logs off, new folders are created on the terminal server. These folders are created for each user in the user_name, user_name.000, user_name.001 format. These folders quickly fill the terminal server's available hard-disk space.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   10-May-2004  22:24  6.0.3790.170   1,057,792  Browseui.dll     
   10-May-2004  22:24  16.0.3790.170    311,296  Iedkcs32.dll     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbBug kbfix kbWinServ2003preSP1fix KB840378 kbAudEndUser kbAudITPRO