Status message files accumulate in the \SMS\inboxes\statmgr\retry folder on a Systems Management Server 2003 site (840301)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

New status messages are not processed, and a backlog of .sql files occur in the \SMS\inboxes\statmgr.box\retry folder. Entries that are similar to the following may be logged in the Statmgr.log file:ERROR: Could not add a SQL command to the transaction. Most likely, there is a problem with the SQL server or our connection to it. The transaction will be rolled back. WARNING: SMS_STATUS_MANAGER could not insert 365 status messages, 1539 insertion strings, and 566 attribute ID/value pairs into the database at this time but retry them in 600000 milliseconds.

CAUSE

This problem may occur when a status message is received that contains a syntax error, such as a carriage return that is embedded in the insertion string data. When the Status Manager component tries to process one of these status messages, the resulting .sql statement is not created correctly. Status Messages that contain the carriage return can be generated by various components, including the Active Directory discovery components. Because the Status Manager component processes oldest files first, new status message files are backlogged until the offending file is processed or deleted.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-Apr-2004  16:24                     13,144  Filemap.ini
   20-Feb-2004  15:03  2.0.6.7           355,242  Smsupdate.exe        
   25-Dec-2003  08:10  2.50.2726.127     221,184  Statmgr.dll
This hotfix can be applied to primary or secondary site servers, although only primary sites would experience this problem.

WORKAROUND

To work around this problem, delete the oldest .sql file in the \SMS\inboxes\statmgr.box\retry folder.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMSTopazFix kbDiscovery kbfix kbBug KB840301 kbAudITPRO