FIX: You receive an error in Windows Media Player 9 Series when you stream certain files by means of Real Time Streaming Protocol (840227)



The information in this article applies to:

  • Microsoft Windows Media Player 9 Series for Windows 2000
  • Microsoft Windows Media Player 9 Series for Windows XP
  • Microsoft Windows Media Player 9 Series for Windows Server 2003

Notice

SYMPTOMS

When you play back content in Microsoft Windows Media Player 9 Series by means of Real Time Streaming Protocol (RTSP), and when you play the content from a server that is running Windows Media Services 9 Series, you may receive the following error:
0xC00D1197 -- Windows Media Player cannot find the specified file. Be sure the path is typed correctly. If it is, the file does not exist at the specified location, or the computer where the file is stored is offline.

CAUSE

This problem occurs because the player has a limit on the data that the player can receive in the response header from the RTSP DESCRIBE method. A content file that has lots of data in the header may be larger than than this limit permits. Content that has lots of data in the header can include script commands or markers.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next release that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsMedia9-KB840227-ENU.exe package now.

For more information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-Apr-2004  20:31  9.0.0.3157        995,840  Wmnetmgr.dll     

MORE INFORMATION

The value of the limit in the player has been increased to permit additional scenarios where there may be lots of data in the Active Streaming Format (ASF) header.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbdownload kbfile kbBug kbfix kbHotfixServer KB840227 kbAudDeveloper kbAudEndUser kbAudITPRO kbAudOEM