An SMS 2003 Advanced Client may copy files from a remote distribution point instead of from a local distribution point when it repairs a package (840198)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When a Microsoft Systems Management Server (SMS) 2003 Advanced Client repairs a package, the Advanced Client may copy files from a remote distribution point instead of from a local distribution point. Therefore, the repair may cause unnecessary wide area network (WAN) traffic.

CAUSE

This problem occurs because Microsoft Windows Installer tries to copy files from the first location that is listed in the distribution source list.

For example, suppose an Advanced Client is assigned to a site and installs a Windows Installer package. The Advanced Client then joins another site that also contains distribution points for this package. The Source Update Manager component updates the list of distribution points, but it leaves the first site's distribution point at the beginning of the source list. In this scenario, Windows Installer uses the first site's distribution point to repair the package instead of the second site's distribution point.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

When you install this hotfix, the SMS site services automatically stop and then restart.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name
   ----------------------------------------------------------------------------
   06-May-2004  06:53                  13,204  Filemap.ini
   06-Aug-2000  00:51  2000.80.194.0  274,489  Ntwdblib.dll
   23-Feb-2003  01:05  2.0.1493.5011  855,312  Preinst.exe
   07-May-2004  20:05  2.50.2726.130  883,944  Sms2003-rtm-kb840198-x86-enu.exe
   25-Dec-2003  02:25                 270,848  Sms2003ac-kb840198-x86.msp
   20-Feb-2004  09:03  2.0.6.7        355,242  Smsupdate.exe
   25-Dec-2003  02:25  2.50.2726.130  171,008  Srcupdatemgr.dll

Installation information

This hotfix updates the SMS Source List Update Agent to version 2.50.2726.0130. This hotfix also updates the Advanced Client.

You must install this hotfix both to primary sites and to secondary sites. Because of new architecture in SMS 2003, you must create a new package and a new program to advertise this hotfix to the Advanced Client computers. We recommend that you let the hotfix installation wizard do this automatically.

To install this hotfix to primary sites and to secondary sites, follow these steps:
  1. Obtain the hotfix file from Microsoft Product Support Services, and then run the self-extracting executable file.

    This creates the Sms2003-rtm-kb840198-x86-enu.exe file.
  2. Copy the Sms2003-rtm-kb840198-x86-enu.exe file to a folder on your site server computer.
  3. Click Start, point to All Programs, point to Systems Management Server, and then click SMS Administrator Console.
  4. Double-click Site Database.
  5. Right-click Collections, point to New, and then click Collection.
  6. In the Name box, type Advanced Clients for 840198.
  7. Click the Membership Rules tab, and then click the yellow button to open Query Rule Properties.
  8. Type a name for the query, and then click Edit Query Statement.
  9. On the General tab, click Show Query Language.
  10. Paste or type the following query in the Query statement area:
    select * from SMS_R_System inner join SMS_G_System_SMS_ADVANCED_CLIENT_STATE on SMS_G_System_SMS_ADVANCED_CLIENT_STATE.ResourceID = SMS_R_System.ResourceId where SMS_R_System.ClientType = 1 and SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Name = "SMSSourceUpdateAgent" and (SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Version < "2.50.2726.0130" or SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Version in ( "2.50.2726.4", "2.50.2726.5", "2.50.2726.18", "2.50.2726.1", "2.50.2726.16" ))
    Note To use this query, you must have at least one Advanced Client computer in your inventory to create the database classes. This query identifies Advanced Client computers that do not have this hotfix installed. Additionally, the query identifies management points that have the Advanced Client installed.
  11. Click OK three times.
  12. On the SMS site server computer, double-click the Sms2003-rtm-kb840198-x86-enu.exe file.

    This starts the installation wizard.
  13. After the installation files are copied, click Yes, I want to create a package and program now, and then click Next.
  14. Click Next to accept the default package name and the default program name.
  15. Complete the installation wizard.
  16. In the SMS Administrator console, double-click Packages.
  17. Right-click the KB840198 - Advanced Client Hotfix package, point to All Tasks, and then click Distribute Software.
  18. Click Next.
  19. Click the distribution points that you want to use, and then click Next three times.
  20. Click Advertise this program to an existing collection, and then click Browse .
  21. Click Advanced Clients for 840198, and then click OK.
  22. Click Next two times.
  23. Click Advertise the program only to members of the specified collection, and then click Next.
  24. Complete the Software Distribution Wizard.
To perform a silent installation of this hotfix, follow these steps:
  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. At the command prompt, switch to the folder that contains the Sms2003-rtm-kb840198-x86-enu.exe file.
  3. Type SMS2003-RTM-KB840198-X86-ENU.exe /s, and then press ENTER.
If you cannot install the Advanced Client part of this hotfix, view the Advanced Client log files on the client computer. The Advanced Client log files are located in the following folders:
  • $Systemroot%\System32\Ccmsetup
  • %Systemroot%\System32\Ccm\Logs

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbAdvertisement kbPackage kbClient kbnetwork kbSMSTopazFix kbUser kbPerformance kbSoftwareDist kbfix kbBug KB840198 kbAudITPRO