Long upload times to a Web page through Internet Explorer 6 (840139)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000

SYMPTOMS

It may take longer than expected to upload a large file to a Web site. The upload operation may time out if are trying to upload a very large file.

CAUSE

This problem may occur if all the following conditions are true:
  • You have installed the security update that is described in Microsoft Security Bulletin MS04-004.
  • The Web page that you are uploading the file to uses the SSL protocol, and the URL starts with "https".
  • The Web page is an active server page or uses scripts to process the uploaded file.

WORKAROUND

You may be able to work around this problem by configuring Internet Explorer to increase the Winsock Send buffer size on the client computer. Configure a 64-KB buffer size to work around this problem.
For more information about how to increase the Winsock Send buffer size, click the following article number to view the article in the Microsoft Knowledge Base:

329781 HTTP file upload operation takes a long time to complete

RESOLUTION

Security update MS05-025

To resolve this problem, you can install the cumulative security update MS05-025. The hotfix for this issue was included in the security update. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

883939 MS05-025: Cumulative security update for Internet Explorer

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Internet Explorer 6 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   05-May-2004  11:55  6.0.2800.1425  571,904  Wininet.dll
				

STATUS

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6.

REFERENCES

For more information about the Microsoft Security Bulletin MS04-004, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbQFE kbIE600sp2fix kbIE600preSP2fix kbfix kbbug kbprb kbHotfixServer KB840139 kbAudDeveloper kbAudEndUser kbAudITPRO