You may intermittently receive a "RMMobile.exe ArgumentException" error when you run Microsoft CRM Mobile 1.2 on a Windows Mobile Pocket PC 2003 device (840059)



The information in this article applies to:

  • Microsoft CRM Mobile, when used with:
    • Microsoft CRM 1.2
  • Microsoft CRM 1.2

SYMPTOMS

When you use Microsoft Business Solutions CRM Mobile 1.2, you may intermittently receive the following error message on a Microsoft Windows Mobile Pocket PC 2003 device or on a Windows Mobile Pocket PC 2003 Phone Edition device:
RMMobile.exe ArgumentException

MbsMoException::Thro+0x25
AbruptStop::TerminateApplication+0x87
CRMAppShell::Main+0xaa

CAUSE

This problem may occur if you use Microsoft CRM Mobile 1.2 on a high resolution Pocket PC device.

Note For this article, a high resolution device is a Pocket PC device that has VGA (480x640) display resolution. At the time of this writing, typical Pocket PC devices have Quarter VGA (QVGA) display resolution (240x320).

This problem occurs because Pocket PC devices that have VGA capabilities were not available when Microsoft CRM Mobile 1.2 was released. Therefore, Microsoft CRM Mobile 1.2 has not been extensively tested on high resolution Pocket PC devices.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Microsoft CRM Mobile 1.2 may work correctly on certain high resolution Pocket PC devices. However, if you receive the error message that is mentioned in the "Symptoms" section, contact Microsoft CRM Support. For more information about how to contact Microsoft CRM Support, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:9/7/2006
Keywords:kbnofix kberrmsg kbBug kbtshoot kbMBSMigrate kbprb kbmsccsearch kbpubtypekc KB840059 kbAudDeveloper