User credentials that are entered by using the UPN format are not authenticated by ISA Server 2000 (840002)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000, when used with:
    • Microsoft Internet Security and Acceleration Server 2000 SP1 + SP2

SYMPTOMS

A user's logon credentials cannot be successfully authenticated by Microsoft Internet Security and Acceleration (ISA) Server when the following conditions are true:
  • The ISA Server 2000 Web Requests listener is configured to use basic authentication.
  • The user credentials are entered by using the user principal name (UPN) format:

    user@example.com

CAUSE

This problem occurs because ISA Server 2000 does not support the UPN format.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next ISA Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must have ISA Server 2000 Service Pack 2 (SP2) installed on your computer. For additional information about how to obtain the latest ISA Server service pack, click the following article number to view the article in the Microsoft Knowledge Base:

313139 How to obtain the latest Internet Security and Acceleration Server 2000 service pack

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Hotfix installation information

To install this hotfix, run the self-extracting executable file. You do not have to restart the ISA Server computer. If the computer is part of an ISA Server array, you do not have to shut down the whole array. You can install this hotfix on a one-by-one basis

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
 Date         Time   Version             Size   File name
--------------------------------------------------------------
28-Jun-2004  09:29  3.0.1200.401      401,400  W3proxy.exe
This hotfix is also available for the French, German, Spanish, and Japanese versions of ISA Server 2000.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you install this hotfix, when users use the UPN format to log on, and when basic authentication is used, the user name is logged in the following format:

domain\username@domain.com

The user name is logged in the Web Proxy log file.

For additional information about how hotfix packages are named and about other terms for software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:9/29/2005
Keywords:kbBug kbfix kbQFE KB840002 kbAudITPRO