SYMPTOMS
When you try to use Microsoft Internet Explorer 6 Service
Pack 1 (SP1) to view a Web page, you may receive an error message that is
similar to the following error message:
The server
returned an invalid or unrecognized response.
CAUSE
This problem may occur if the following conditions are true:
- You have installed the cumulative security update for
Internet Explorer MS04-004.
- You try to access a Web page that is secured by basic
authentication.
This problem occurs after you apply the cumulative security
update for Internet Explorer MS04-004. When you access a Web page that uses
basic authentication, Internet Explorer sends a HEAD request with an
authorization header through the same port that was used to send the first HEAD
request. When Internet Explorer sends a HEAD request for a resource that uses
basic authentication, the Web server may return a "401 Access Denied" message
and a "Connection: close" message. If Internet Explorer then sends the HEAD
request with an authorization header that uses the same port that was used for
the first HEAD request, an error occurs. The same port must not be used again
because the Web server prompted for the connection to be closed when the "401
Access Denied" status message was returned to Internet Explorer.
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.
To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
File information
The English version of this hotfix has the file
attributes (or later) that are listed in the following table. The dates and
times for these files are listed in coordinated universal time (UTC). When you
view the file information, it is converted to local time. To find the
difference between UTC and local time, use the
Time Zone tab
in the Date and Time tool in Control Panel.
Date Time Version Size File name
-------------------------------------------------------
05-Apr-2004 09:10 6.0.2800.1415 570,880 Wininet.dll