DNS removes a Network Name resource at the end of the default scavenging interval in Windows Server 2003 (838851)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition

SYMPTOMS

After you use the Cluster Administrator Console to bring a Network Name resource online, you notice that the DNS record for the resource is removed after seven days. You must take the Network Name resource offline, and then bring the resource back online to restore the record.

CAUSE

This problem occurs because the 24-hour DNS record update interval is reset after you bring a Network Name resource online. The Cluster service does not update the DNS records on the default 24-hour interval. By default, the DNS scavenging interval is seven days. At the end of the scavenging interval, DNS removes the Network Name record because the Time to Live (TTL) value has expired.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
-----------------------------------------------------------------
12-Mar-2004  21:02  5.2.3790.140    1,072,128  Clusres.dll  IA-64
Date         Time   Version            Size    File name
----------------------------------------------------------------
12-Mar-2004  22:01  5.2.3790.140      449,536  Clusres.dll  x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbClustering kbDNS kbServer kbWinServ2003preSP1fix kbfix kbBug KB838851 kbAudITPRO