"The name could not be resolved" error message when you try to verify the mailbox name during MAPI profile creation on Exchange 2000 Server or on Exchange Server 2003 (838800)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

If you try to create a MAPI profile by using the Microsoft Outlook client, you receive the following error message when you click Check Name to verify your settings:
The name could not be resolved. The operation failed.

CAUSE

This problem may occur if the client computer is configured to use a localized language that is not installed on the global catalog server that the computer that is running Microsoft Exchange 2000 Server or Microsoft Exchange Server 2003 connects to.

RESOLUTION

To resolve this problem, follow these steps on the global catalog server:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Regional Options.
  3. Click the General tab.
  4. Under Language settings for the system, click to select the check boxes for the languages that you want the Exchange 2000 server or the Exchange Server 2003 server to support.
  5. Click OK.

    You receive a message to insert the Microsoft Windows 2000 Server CD-ROM or the Microsoft Windows Server 2003 CD-ROM.
  6. Insert the Windows 2000 Server CD-ROM or the Microsoft Windows Server 2003 CD-ROM, and then click OK.
  7. When you receive a message to restart your computer, click Yes.
You must also configure the correct locale setting and the correct language setting on the computer that is running the Outlook client. After you configure these settings, you must restart the client computer. For additional information about how to configure language settings on different Windows operating systems, click the following article number to view the article in the Microsoft Knowledge Base:

177561 HOW TO: Add and enable additional languages in Windows

MORE INFORMATION

In Microsoft Exchange Server 5.0 and in Microsoft Exchange Server 5.5, the national language support (NLS) files are copied to the Exchange server when you run the Setup program on the Exchange server. The NLS files are copied to support IMAIL and to support access to the Exchange directory by localized MAPI clients. For language support in Exchange Server 4.x, you had to manually copy files, register the files, and then add the Exchsrvr.inf file from the Langpack folder on the Microsoft Windows NT Server 4.0 CD-ROM.

Note The IMAIL sub-component of the Microsoft Exchange Information Store service (Store.exe) performs content conversion to convert an e-mail message from Microsoft Database Format (MDBEF) to Simple Mail Transfer Protocol (SMTP) MIME format or to UUencode format.

This behavior is different in Exchange 2000 Server and in Exchange Server 2003. Because Exchange 2000 Server and Exchange Server 2003 require the implementation of the Windows 2000 Active Directory directory service, Exchange name registration is done through a global catalog server. When you run the Setup program for Windows 2000 Server, the NLS files are copied and registered. However, the NLS files that are installed may vary depending on the language locales that the administrator installs.

By default, not all language locales are installed. This behavior is not an issue in IMAIL. However, when you try to resolve names while you are creating MAPI profiles by using a localized MAPI client, you may experience the problem that is mentioned in the "Symptoms" section.

If you receive an error message that is similar to the error message that is mentioned in the "Symptoms" section, and the global catalog server does not meet the conditions that are mentioned in the "Cause" section, click the following article number to view the article in the Microsoft Knowledge Base:

297801 Troubleshooting Check Name errors

REFERENCES

For additional information about language locales that are not installed by default in Windows 2000, click the following article number to view the article in the Microsoft Knowledge Base:

294343 Some locales for language groups are not available in the Regional Options


Modification Type:MajorLast Reviewed:4/13/2004
Keywords:kberrmsg kbprb KB838800 kbAudITPRO