FIX: Speech engines do not work and you receive an error message when you open Speech Control Panel (838659)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Speech Software Development Kit (SDK) 5.1

SUMMARY

When you use speech engines to do recognition or synthesis, you can save the CurrentUserLexicon file on your local hard disk to store additional words. Sometimes, the CurrentUserLexicon file can become corrupted. When this happens, the speech recognition (SR) engine and the text-to-speech (TTS) engine do not work. This article describes possible causes and fixes the problem with a hotfix file.

SYMPTOMS

The speech recognition (SR) engine and the text-to-speech (TTS) engine do not work in any applications. When you open Speech Control Panel, you may receive the following message:
The requested task cannot be carried out because the necessary speech engine could not be created. Please select a different engine and/or a different audio device.

CAUSE

Currently, the specific cause of the problem is not known. However, the following are possible causes:
  • An incorrectly configured audio device
  • A corrupted recording profile
  • A corrupted user lexicon database (CurrentUserLexicon)
To determine whether CurrentUserLexicon is corrupted, use a hexadecimal editor to open the .dat file that is located in the following folder:

\Documents and Settings\UserName\Application Data\Microsoft\Speech\Files\UserLexicons

If the file contains only 0x00 byte values and contains no other data values, the user lexicon database has likely been corrupted.

WORKAROUND

To work around this problem, delete the corrupted user lexicon file. The system then re-creates an empty version of the file. After this, the SR engine and the TTS engine can function.

Note If you delete the user lexicon file, you lose any user-specific vocabulary that was previously added.

To delete the user lexicon file, delete the following folder:

\Documents and Settings\UserName\Application Data\Microsoft\Speech\Files\UserLexicons

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version     Size     File name
   --------------------------------------------------
   09-Mar-2004  22:26  6.0.1518.0  696,320  Sapi.dll

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbfix kbQFE kbHotfixServer KB838659 kbAudDeveloper