Computer stops responding when a SCSI miniport driver issues a ScsiPortNotification(BusChangeDetected) call (838637)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2003
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

When a SCSI miniport driver issues a ScsiPortNotification with a (BusChangeDetected) notification type, the computer may stop responding.

CAUSE

A problem in the SCSIport.sys driver causes the computer to stop responding.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 or Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required for the Windows Server 2003 version of this hotfix.
For the Windows XP version of this hotfix, you must be running Windows XP SP1.
For the Windows 2000 version of this hotfix, you must be running Windows 2000 SP3 or Windows 2000 SP4.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name     Platform
-----------------------------------------------------------------------------------------------
22-Mar-2004  01:58  5.2.3790.142      127,488  Scsiport.sys  Windows Server 2003
22-Mar-2004  01:55  5.2.3790.142      292,352  Scsiport.sys  Windows Server 2003 64-Bit Edition
21-Mar-2004  22:38  5.1.2600.1365      90,624  Scsiport.sys  Windows XP
21-Mar-2004  22:38  5.1.2600.1365     305,408  Scsiport.sys  Windows XP 64-Bit Edition
09-Mar-2004  18:54  5.0.2195.6906      74,128  Scsiport.sys  Windows 2000

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWin2000preSP5fix kbWinXPpreSP2fix kbBug kbfix kbWinServ2003preSP1fix KB838637 kbAudITPRO kbAudDeveloper