FIX: The worker process may fail when you host a Commerce Server 2002 site in IIS 6 on a computer that is running Windows Server 2003 (838466)



The information in this article applies to:

  • Microsoft Commerce Server 2002

SYMPTOMS

When you host a Microsoft Commerce Server 2002 site in Microsoft Internet Information Services (IIS) 6 on a computer that is running Microsoft Windows Server 2003, the worker process may fail and you may experience the following symptoms:
  • Clients may receive the following error message from the browser:
    Error Type: Microsoft VBScript runtime
    Page: /Store/login/Login.asp
    File: /Store/include/std_profile_lib.asp
    Line:329
    800A01FB
    An exception occurred: 'MSCSProfileService.GetProfile'
    Note: Set Application("MSCSEnv") = DEVELOPMENT to turn on client error messages.
    Note: Please see error\500error.asp to further customize error messages.
  • The following events may be logged to the event log. These events indicate a failure to shut down the profile services during the IIS application pool:Event Type: Error
    Event Source: Application Error
    Event Category: (100)
    Event ID: 1000
    Description: Faulting application w3wp.exe, version 6.0.3790.0, faulting module mscsups.dll, version 4.5.3320.0, fault address 0x00009022.Event Type: Information
    Event Source: Application Error
    Event Category: (100)
    Event ID: 1000
    Description: Reporting queued error: faulting application w3wp.exe, version 6.0.3790.0, faulting module mscsups.dll, version 4.5.3320.0, fault address 0x00009022.Event Type: Information
    Event Source: Application Error
    Event Category: (100)
    Event ID: 1004
    Description:
    Faulting application w3wp.exe, version 6.0.3790.0, faulting module CSRockall.DLL, version 4.5.3810.0, fault address 0x00005d0a.

CAUSE

This problem occurs because the Commerce Server 2002 OLE DB Provider (Csoledbprovider.dll) may unexpectedly unload. The profile service depends on Csoledbprovider.dll to provide database connections.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Commerce Server 2002 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart IIS after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size       File name
   --------------------------------------------------------------
   25-May-2005  19:50  4.5.3873.0  1,004,072  Csoledbprovider.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

WORKAROUND

To minimize the risk that the Commerce Server profile services will shut down and fail with an error message, disable the following options for recycling:
  • Configure a worker process to be recycled after a set elapsed time.
  • Configure a worker process to be recycled after a set number of processing requests.
  • Configure a worker process to be recycled at scheduled times.
  • Configure a worker process to be recycled after it uses a set amount of memory.
For more information, visit the following Microsoft Web site:

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

When you experience this problem, you may notice the following sequence of events:
  1. The server will operate successfully for some time.
  2. By design, IIS 6 recycling may be triggered for one of the following reasons:
    • Resource exhaustion occurred.
    • Several errors were detected.
    • Requests may be queued.
    • IIS detected no response.
  3. A worker process shutdown operation may be initiated.
  4. After the worker process shuts down, profile service method calls including the GetProfileByKey method fail. This behavior may occur because the Commerce Server 2002 OLE DB Provider has been unloaded.
  5. IIS logs Error 100 and notes that Mscsups.dll or CSRockall.dll is the failing component.
  6. IIS restarts the appropriate worker process.

Excess Commerce API initialization calls may cause the worker process to be recycled

For more information about a scenario where this problem may occur, click the following article number to view the article in the Microsoft Knowledge Base:

830802 You may experience problems on your Web server if your Web site is based on the Retail2002 SDK sample site

Note Excess Commerce API initialization calls may cause you to receive error messages and the worker process may be recycled. These calls may include calls to the SiteConfigReadOnly.Initialize method. You may also experience these symptoms during scheduled recycling of the application.

Creating and initializing the AuthManager object

The AuthManager object uses site configuration resource properties. When the AuthManager object is first initialized, the object creates a site cache and populates the cache with these properties. If the AuthManager object is initialized again, the object examines the cache for these properties. If the properties are not found, the properties are loaded again. An instance of the AuthManager object is created and initialized on every page that uses the AuthManager object and in the Global.asa file for the site for performance reasons.

For more information, visit the following Microsoft Developer Network (MSDN) Web site: For more information about other issues that may contribute to excessive resource utilization, click the following article number to view the article in the Microsoft Knowledge Base:

322816 Commerce Profile Services returns E_OutofMemory


Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbfix kbBug kbCommServ2002preSP4fix KB838466 kbAudDeveloper