Other project plans are missing in Project Center after you publish your project plan to Microsoft Office Project Server 2003 (838347)



The information in this article applies to:

  • Microsoft Office Project Server 2003

SYMPTOMS

After you publish your project plan in Microsoft Office Project Professional 2003, only one project plan may appear in Project Center. Additionally, e-mail notifications for assigned tasks may not be sent out.

CAUSE

This problem may occur if multiple Project Managers publish their Microsoft Office Project 2003 project plans at the same time to Microsoft Office Project Server 2003.

WORKAROUND

To view the other project plans in the Project Center, close the project plan that you published in Project Professional 2003.

RESOLUTION

How to obtain the hotfix

This issue is fixed in the Microsoft Office Project Server 2003 Hotfix Package . For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

838882 Microsoft Office Project Server 2003 hotfix package

Note After you install this hotfix, you must follow the steps that are listed in the "More Information" section to start the hotfix on the server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Important Simple Mail Transfer Protocol (SMTP) must be installed on your Project Server 2003-based computer that is running Internet Information Services (IIS), and it must be configured to forward e-mail to the SMTP server.

To make sure that all the fixes that this hotfix contains are applied correctly on Project Server 2003, follow these steps:
  1. Run the self-extracting package to extract the files in a temporary folder that you select.
  2. For each SQL query file (such as the Websps.sql file) that is extracted to the temporary folder that you selected in step 1, use one of the following steps:
    • If you are using Microsoft SQL Server as the back end for Project Server 2003, follow these steps:
      1. On the main SQL server in your configuration, run SQL Query Analyzer.
      2. In the Database box, click the ProjectServer database.
      3. On the File menu, click Open, locate the SQL query file in the temporary folder that you selected in step 1, and then open the file.
      4. On the Query menu, click Execute.
      5. When the query has finished running, you can quit SQL Query Analyzer.
    • If you are using SQL Server Desktop Engine (also known as MSDE 2000) as the back end for Project Server 2003, follow these steps:
      1. On the main SQL server in your configuration, click Start, click Run, type osql -i tempdir\queryfile.sql -U sa in the Open box, and then click OK.

        For example, if you extracted the files in step 1 to the C:\Temp folder, and if the name of the query file is Websps.sql, type osql -i c:\temp\websps.sql -U sa in the Open box.

        This command connects you to the local default instance of MSDE 2000 by using the system administrator (SA) account. You can also run the osql command with another user name that has SA permissions on the server.
      2. At the Password prompt, type the password for the account that you used in step a, and then press ENTER. The SQL query file that you specified in step a runs.

Additional steps

To start this hotfix, follow these steps:
  1. In Notepad, type or paste the following SQL code in a new file:
    update MSP_WEB_ADMIN set WADMIN_SMTP_SERVER_NAME=NULL

    GO
  2. On the File menu, click Save As.
  3. Change the Save in box to the temporary folder that you selected in step 1 of the "More Information" section.
  4. In the File name box, type a name for your SQL file. For example, type Activate.sql in the File name box.
  5. Change the Save as type box to Text Documents (*.txt).
  6. Click OK to save your SQL file.
  7. To start this hotfix, perform step 2 in the "More Information" section for the new SQL file that you saved in steps 1 through 5 of this section.
Important After you start this hotfix, the SMTP server name in Project Web Access will be blank. If the administrator clicks Save on the Notifications and Reminders page in Project Web Access, a dialog box will appear indicating that the SMTP server name must be entered and saved to turn on e-mail notifications and reminders. The administrator must click OK to ignore this dialog box. If the SMTP server name is typed in the dialog box and saved, the hotfix that is described in this article will be deactivated.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbbug KB838347 kbAudITPRO kbAudEndUser