Some applications cannot access the serial port in Windows Server 2003 (838291)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

Some applications may not be able to communicate through the COM serial port on your Microsoft Windows Server 2003-based computer. You may experience this problem with custom applications that use the "return quickly" feature of the Windows COM port driver. For example, this problem may occur with custom applications that use the serial port control (MsComm32.ocx) that is included with Microsoft Visual Basic 6.0.

CAUSE

This problem occurs because the redirected port implementation sets the status to pending, and this affects serial COM software that relies on the "return quickly" feature.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003 64-Bit Edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Apr-2004  14:53  5.2.3790.163      597,504  Rdpdr.sys
   12-Apr-2004  19:56                        271  Branches.inf
   19-Apr-2004  16:48                      9,766  Kb838291.cat
   19-Apr-2004  16:41                        354  Updatebr.inf
   19-Apr-2004  16:42                      6,249  Update_rtmqfe.inf
Windows Server 2003 32-bit editions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Apr-2004  17:42  5.2.3790.163      188,416  Rdpdr.sys
   12-Apr-2004  22:56                        271  Branches.inf
   19-Apr-2004  19:48                      9,766  Kb838291.cat
   19-Apr-2004  19:37                        354  Updatebr.inf
   19-Apr-2004  19:37                      5,987  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbSerial kbConnPts kbCOMServices kbWinServ2003preSP1fix kbHardware kbinterop kbfix kbBug KB838291 kbAudITPRO kbAudDeveloper