You receive the "Your search encountered an error" error message when you search a SharePoint Portal Server 2003 site (838223)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003

SUMMARY

This article discusses a problem that you may experience when you perform a search query on a server that is running Microsoft Office SharePoint Portal Server 2003, and the search generates the following error message:
Your search encountered and error. If the problem persists, contact the portal site administrator.
This error message occurs when you remove an Index Server from a topology without removing the CatalogName catalog from the Index Server first.

SYMPTOMS

When you perform search query on a server that is running Microsoft Office SharePoint Portal Server 2003, you may receive the following error message:
Your search encountered and error. If the problem persists, contact the portal site administrator.
If you view the event log, you may receive the following error message:
Event Type: Error
Event Source: Microsoft SharePointPS Search Service
Event Category: Search service
Event ID: 7043
Date: Date
Time: Time
User: N/A
Computer: Computer_name
Description:
The index cannot be loaded.

Context: http://portalurl/ Application, CatalogName Catalog

Details:
The content index cannot be enabled because its propagation version cannot be verified against the dedicated index server. This can occur when either the dedicated index server is offline or the content index is out-of-date. (0x80040427)

For more information visit
http://www.microsoft.com/servers/redirect/contentredirect2.asp
For more information, see Help and Support Center at
http://support.microsoft.com.

CAUSE

This problem may occur when the Index Server that holds the CatalogName catalog is taken out of the topology through the SharePoint Portal Administration program. If the search server is then restarted or the appropriate services are restarted, the search server will try to contact the Index Server that is holding the CatalogName catalog. If the Index Server is not available or is not responding, the catalog is marked as disabled.

If any catalog is disabled on a search box, the catalog is removed from the query load balancing. This means that if all the search servers in your server farm enter into this condition, there will be no search servers to respond to the query, and the users will receive the error message that is mentioned in the "Applies To" section when submitting queries.

WORKAROUND

To work around this problem, add the Index Server back into the topology and create an empty CatalogName catalog on this Index Server. You can then manually set the PropSequenceNumber key in the registry so that the search server can validate the catalog.

You must remove the catalogs that are not correct from the Index Server before you add the Index Server to the topology. To do this, you must use the Catutil.exe tool. After you remove the appropriate catalogs, you must restart the search servers.

Note If you intend to add the catalog back to the Index Server, you must rebuild the catalog first, and then re-propagate the catalog.

For additional information about how to use the Catutil.exe tool, click the following article number to view the article in the Microsoft Knowledge Base:

825484 How to use the Catutil.exe tool

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about how to initiate an Index Server for a SharePoint Portal Server 2003 site, click the following article number to view the article in the Microsoft Knowledge Base:

823207 HOW T0: Make SharePoint Portal Server Help files searchable on the portal site

REFERENCES

For more information about how to configure and administer SharePoint Portal Server 2003, see the Microsoft Office SharePoint Portal Server Administrator's Guide (Administrator's Help.chm). The Microsoft Office SharePoint Portal Server 2003 Administrator's Guide and Microsoft Office SharePoint Portal Server 2003 Help (User's Help.chm) are located in the Docs folder of the SharePoint Portal Server 2003 CD-ROM.

For more information about SharePoint Portal Server 2003, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:9/22/2006
Keywords:kberrmsg kbnofix kbBug KB838223 kbAudITPRO kbAudEndUser