FIX: Bitmaps are incorrectly colored on the mirrored display in Windows Server 2003 (837996)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

For a Microsoft Windows XP version of this article, see 834709.

SYMPTOMS

When you try to display an 8-bit bitmap or an indexed color depth bitmap on a computer with a mirrored display, the bitmap appears incorrectly colored on the mirrored display. The color palette in the image is incorrectly re-mapped to other color palettes.

CAUSE

This problem occurs when the color depth of the mirrored display is greater than the color depth of the primary display.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name      Platform
   ----------------------------------------------------------------------
   14-Oct-2004  06:41  5.2.3790.222    4,958,208  win32k.sys     IA-64
   14-Oct-2004  22:03  5.2.3790.222    1,815,040  win32k.sys     x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbWinServ2003preSP1fix kbQFE kbfix kbBug KB837996 kbAudITPRO kbAudDeveloper