FIX: An access violation occurs under low memory conditions in your Visual C++ .NET application (837895)



The information in this article applies to:

  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition

SYMPTOMS

Under low memory conditions, when you run an application that was created in Microsoft Visual Studio .NET by using Microsoft Visual C++ .NET, the application may experience an access violation and may quit unexpectedly. This problem occurs if the application uses the Microsoft Visual C++ Runtime Library.

CAUSE

This problem occurs because memory allocation failures prevent an internal string buffer from being initialized in the Visual C++ Runtime Library.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Visual Studio .NET 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time      Version      Size       File name
   ----------------------------------------------------------------------
   26-Feb-2004  21:07:40  7.10.4058.0    544,768  Msvcr71d.dll
   26-Feb-2004  21:07:40               1,788,928  Msvcr71d.pdb
   26-Feb-2004  21:49:09  7.10.4058.0    348,160  Msvcr71.dll
   26-Feb-2004  21:49:09               2,370,560  Msvcr71.pdb
   26-Feb-2004  20:58:41               2,707,386  Libc.lib
   26-Feb-2004  20:58:41                  94,208  Libc.pdb
   26-Feb-2004  21:04:15               3,023,194  Libcd.lib
   26-Feb-2004  21:04:15                  94,208  Libcd.pdb
   26-Feb-2004  21:00:50               2,937,294  Libcmt.lib
   26-Feb-2004  21:00:50                 102,400  Libcmt.pdb
   26-Feb-2004  21:06:17               3,304,518  Libcmtd.lib
   26-Feb-2004  21:06:17                 102,400  Libcmtd.pdb
   26-Feb-2004  20:55:26                 366,090  Eh.lib
   26-Feb-2004  20:55:46                 363,738  Eh.lib
   26-Feb-2004  20:56:06                 400,836  Eh.lib
   26-Feb-2004  20:56:24                 384,118  Eh.lib
   26-Feb-2004  20:56:40                 382,120  Eh.lib
   26-Feb-2004  20:56:56                 414,180  Eh.lib
   29-Feb-2004  11:37:41                 201,728  VC_User_CRT71_RTL_X86_---.msm

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

The following is an example of the stack trace that you see when you experience this problem.

Note The strlen function does not cause this problem. This problem occurs when the strlen function tries to operate on the uninitialized data.

01 MODULE!strlen(void)+0x30
02 MODULE!exception::exception+0x20
03 MODULE!std::_Nomemory(void)+0x4f

To obtain the call stack for this problem, you can use the ADPlus tool. ADPlus is a tool from Microsoft Product Support Services (PSS) that can troubleshoot any process or application that stops responding or quits unexpectedly.

For additional information about the ADPlus tool, click the following article number to view the article in the Microsoft Knowledge Base:

286350 HOW TO: Use ADPlus to troubleshoot "hangs" and "crashes"

For additional information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbVSNET2003sp1fix kbfix kbBug KB837895 kbAudDeveloper