Logical Disk Manager stops responding or reports an error when you hot-swap a dynamic disk in Windows Server 2003 (837814)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you hot-swap a dynamic disk, Logical Disk Manager occasionally stops responding or reports an error. You may receive the following event messages in System Event Viewer: Event Log Description:
Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7034
Date: Date
Time: Time
User: N/A
Computer: Computer_Name
Description:
The Logical Disk Manager Administrative Service service terminated unexpectedly. It has done this 2 time(s).

For more information, see Help and Support Center at http://support.microsoft.com. Event Type: Error
Event Source: Virtual Disk Service
Event Category: None
Event ID: 10
Date: Date
Time: Time
User: N/A
Computer: Computer_Name
Description:
Unexpected provider failure. Restarting the service may fix the problem. Error code: 80042420@02000034

For more information, see Help and Support Center at http://support.microsoft.com.

CAUSE

This problem occurs because, after you remove the disk, an access violation occurs in the Dmadmin service when the Logical Disk Manager rescans to change the disk's state to missing.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name          Platform
   ----------------------------------------------------------------------
   01-Mar-2004  22:45  5.2.3790.134  946,176  Dmconfig.dll       IA-64
   01-Mar-2004  18:25                    271  Branches.inf
   01-Mar-2004  22:57                  9,766  Kb837814.cat
   01-Mar-2004  22:51                    354  Updatebr.inf
   01-Mar-2004  22:51                  6,285  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/20/2006
Keywords:kbHotfixServer kbQFE kberrmsg kbBug kbfix kbQFE kbWinServ2003preSP1fix KB837814 kbAudEndUser kbAudITPRO