You receive a "SYSTEM ERROR (0x80004005)" error message in the Project Server Spooler dialog box when you publish a project to Microsoft Project Server 2002 SP1 in a distributed environment (837609)



The information in this article applies to:

  • Microsoft Project Server 2002

SYMPTOMS

When you publish a project to a server after you install Microsoft Project Server 2002 Service Pack 1 (SP1) on servers that are running Microsoft Project Server 2002 in a distributed environment, you receive the following error message in the Microsoft Project Server Spooler dialog box:
SYSTEM ERROR (0x80004005)

CAUSE

This issue occurs because, when you run the Setup program to install Project Server 2002 SP1 on servers that are in a distributed environment, the Setup program resets certain registry settings to the default settings. The registry settings that you modified to configure Project Server 2002 to run with an application server in a distributed environment are reset to use the default settings. For example, the value of the Default registry entry that you configured in the following registry key is reset:

HKEY_LOCAL_MACHINE\Software\Microsoft\Office\10.0\MS Project\WebClient Server\<Virtual Directory>\Services\SessionMgr\<GUID>

WORKAROUND

To work around this issue, modify the registry entries that were reset by the Setup program to use the settings that are required for a distributed deployment of Project Server 2002. For more information about how to set up Project 2002 in a distributed environment, visit the following Microsoft Web site:

MORE INFORMATION

For more information about how to customize and deploy Project 2002 in your organization, see the Microsoft Project 2002 Resource Kit. To view the Microsoft Project 2002 Resource Kit, visit the following Microsoft Web site: For additional information about Project Server 2002 SP1, click the following article number to view the article in the Microsoft Knowledge Base:

830240 Description of Microsoft Project Server 2002 Service Pack 1


Modification Type:MinorLast Reviewed:9/14/2004
Keywords:kbsetup kbprb KB837609 kbAudITPRO