Several orphaned Csrss.exe processes cause performance issues on your Windows 2000-based terminal server (837585)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP4

Windows SE:93900

SYMPTOMS

On your Microsoft Windows 2000 Server-based computer or your Microsoft Windows Server 2003-based computer that is running Terminal Services, you may experience the following symptoms:
  • The server becomes slow and unresponsive. Eventually, you cannot establish new Terminal Services sessions.
  • If you use Task Manager to view the running processes, you may see that there are several orphaned Csrss.exe processes. There are no corresponding Terminal Services client sessions when you view the sessions in Terminal Services Manager.
  • You cannot stop the orphaned Csrss.exe processes to free server resources. Therefore, the Csrss.exe processes may continue to accumulate until you must restart the server to free memory and CPU resources.
If you apply the hotfix that is described in the Microsoft Knowledge Base article 827350, this may help reduce the number of Csrss.exe processes, but you still experience the problem.

827350 Clients cannot connect to a terminal server when Csrss.exe and Termsrv.exe spike at 100 percent CPU usage

CAUSE

The problem occurs because of a regression that was introduced in Windows 2000 Service Pack 3 (SP3). Windows 2000 SP3 includes a fix that introduces a temporary winstation object in the Csrss.exe process. This fix is described in the following Microsoft Knowledge Base article:

261322 Stop 0x0000001E error message when you print from a Windows 2000 Terminal Services client

If the temporary winstation objects are not released correctly, you may experience the symptoms that are described earlier in this article.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Windows 2000 Service Pack 3 or later.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows 2000 Server

   Date         Time   Version         Size       File name
   -----------------------------------------------------------
   24-Mar-2004  02:17  5.0.2195.6824      42,256  Basesrv.dll      
   21-Sep-2003  00:45  5.0.2195.6824     236,304  Cmd.exe          
   19-Jun-2003  20:05  5.0.2195.6660     233,744  Gdi32.dll        
   24-Mar-2004  02:17  5.0.2195.6897     742,160  Kernel32.dll     
   24-Mar-2004  02:17  5.0.2195.6824      54,544  Mpr.dll          
   27-May-2004  19:40  5.0.2195.6930     335,120  Msgina.dll       
   24-Mar-2004  02:17  5.0.2195.6892      90,264  Rdpwd.sys
   16-May-2004  19:43  5.0.2195.6928   5,873,664  Sp3res.dll       
   24-Mar-2004  02:17  5.0.2195.6897     403,216  User32.dll       
   05-Aug-2003  22:14  5.0.2195.6794     385,808  Userenv.dll      
   27-May-2004  00:21  5.0.2195.6934   1,630,992  Win32k.sys
   11-Mar-2004  02:37  5.0.2195.6898     181,520  Winlogon.exe     
   27-May-2004  19:40  5.0.2195.6934     243,984  Winsrv.dll       
   24-Mar-2004  02:17  5.0.2195.6897     742,160  Kernel32.dll     
   27-May-2004  00:21  5.0.2195.6934   1,630,992  Win32k.sys
   27-May-2004  19:40  5.0.2195.6934     243,984  Winsrv.dll 

Windows Server 2003 x86

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   04-May-2004  23:28  5.2.3790.170      291,840  Winsrv.dll       
   21-Apr-2004  16:35                        271  Branches.inf
   04-May-2004  23:39                      9,766  Kb837585.cat
   04-May-2004  23:29                        354  Updatebr.inf
   04-May-2004  23:29                      5,647  Update_rtmqfe.inf

Windows Server 2003 ia64

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-May-2004  00:22  5.2.3790.170      764,928  Winsrv.dll       IA64
   21-Apr-2004  17:35                        271  Branches.inf
   05-May-2004  00:39                      9,766  Kb837585.cat
   05-May-2004  00:30                        354  Updatebr.inf
   05-May-2004  00:30                      5,667  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This feature was first included in Windows Server 2003 Service Pack 1.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New naming schema for Microsoft Windows hotfix packages

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB837585 kbAudITPRO