IDE may stop responding when you open an automated managed project in Windows 2000 (837443)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you open an automated managed Microsoft Visual Studio .NET 2003 project in Microsoft Windows 2000, the IDE (Devenv.exe) may stop responding (hang).

CAUSE

This problem may occur if the memory manager makes repeated calls to virtual memory (VirtualAlloc).

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows 2000 Service Pack 4 (SP4) or Windows 2000 SP3 installed to install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   10-Feb-2004  12:47  5.0.2195.6897     30,160  Mountmgr.sys
   05-Apr-2004  13:39  5.0.2195.6921  1,700,928  Ntkrnlmp.exe
   05-Apr-2004  13:39  5.0.2195.6921  1,700,608  Ntkrnlpa.exe
   05-Apr-2004  13:39  5.0.2195.6921  1,722,176  Ntkrpamp.exe
   05-Apr-2004  13:39  5.0.2195.6921  1,677,824  Ntoskrnl.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB837443 kbAudEndUser kbAudDeveloper