Windows 2000 Terminal Server stops responding after you experience access violations in a Terminal Server session (837439)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server

SYMPTOMS

You may experience several access violations when you run a program in a Terminal Server session. The access violations can cause the program that you are using to stop responding or to abruptly quit. This scenario may eventually cause the Microsoft Windows 2000 Terminal Server to stop responding.

CAUSE

This problem occurs when the Terminal Server application compatibility DLL (Tsappcmp.dll) allocates a buffer for the PATH environment variable that is longer than 260 characters. This buffer is not overwritten. Instead, Terminal Server puts a NULL terminator at the end of the buffer allocation. When the TermsrvCreateKey function makes a call to the NtQueryKey function, the NtQueryKey function returns a data string that exceeds the maximum path size. This scenario may cause a kernel-mode failure in Windows 2000.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Mar-2004  23:06  5.0.2195.6860      49,424  Tsappcmp.dll     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB837439 kbAudITPRO