Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
CAUSE
This problem occurs if all the following conditions are true:
- You apply the hotfix that is described in the following Microsoft Knowledge Base (KB) article to your Exchange 2000 computers:
810326 Folder names may be changed to Hebrew in migration from Exchange Server 5.5 to Exchange 2000 Server
Particularly, you install this hotfix on the destination mailbox server of the mailbox move operation. - You move a user's mailbox to a different Exchange 2000 computer.
- You create a new Outlook profile for the user whose mailbox you moved.
In this scenario, after you configure localization for the user's mailbox by applying the 810326 hotfix, when the user first logs on by using a new Outlook profile, Outlook automatically adds the word "Mailbox" to the mailbox display name. Additionally, Outlook populates a registry value for that user's profile with this mailbox display name information. When Outlook successfully logs on to the mailbox for the first time, Outlook retrieves the mailbox display name from the Exchange 2000 computer and overwrites the user's profile information with the information that Outlook receives from the Exchange 2000 computer. This problem occurs because the Exchange 2000 computer does not have the word "Mailbox" in the mailbox display name.
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
Because of file dependencies, this update requires both of the following:
- Microsoft
Exchange 2000 Server Service Pack 3 (SP3).
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378
How to obtain the latest Exchange 2000 Server service pack
- The hotfix rollup package that is described in the following Microsoft Knowledge Base (KB) article:
870540 Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup
Restart requirement
You do not have to restart your computer after you apply this hotfix. However, the following service is automatically stopped and then restarted when you apply this hotfix:
- Microsoft Exchange Information Store
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
------------------------------------------------------------
09-Jul-2004 02:59 6.0.6608.0 2,310,144 Mdbmsg.dll
09-Jul-2004 03:50 6.0.6608.0 4,677,632 Store.exe
WORKAROUND
To work around this problem, apply the registry entry that is described in KB 810326 to a destination Exchange 2000 mailbox server, and then move the affected user's mailbox to that new server. To do this, follow these steps.
Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
- On the destination Exchange 2000 mailbox server, click Start, click Run, type regedit, and then click OK.
- Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
- On the Edit menu, point to New, and then click DWORD Value.
- In the New Value #1 box, type Localize On First Logon, and then press ENTER.
- Right-click Localize On First Logon, and then click Modify.
- In the Value data box, type 1, and then click OK.
- Quit Registry Editor.
- Move the user's mailbox to the new Exchange 2000 mailbox server.
- Create a new Outlook profile for the affected user.