The Active Directory Migration Tool displays a "RPC server is unavailable" error message in Windows Small Business Server 2003 (837366)



The information in this article applies to:

  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

When you try to use the Active Directory Migration Tool to migrate computer accounts from Microsoft Small Business Server 2000 to Microsoft Windows Small Business Server 2003, the Active Directory Migration Tool Agent Monitor opens and displays details that are similar to the following:

On the Server List tab, the Active Directory Migration Tool Agent Monitor displays Install Failed under Status. Under Message, the Active Directory Migration Tool displays The RPC server is unavailable.

When you click View Dispatch Log in the Active Directory Migration Tool Agent Monitor, you see an error message that is similar to the following:
Date Time ERR2:7625 Unable to connect to \\Computer.Domain.local\ADMIN$ The machine might be down or its Server, Netlogon service might not be started. rc=1722 The RPC server is unavailable. DateTime ERR2:7014 The Active Directory Migration Tool Agent Service on \\Computer.Domain.local did not start. See the application log on \\Computer.Domain.local for details.
When this error occurs, the Active Directory in Windows Small Business Server 2003 will contain the computer account for the computer that caused the error. However, the migration is not complete because the client computer is not joined to the destination domain.

CAUSE

This behavior may occur if one or more of the following conditions are true:
  • The client computer that is listed in the Dispatch.log file error message does not have file and printer sharing turned on. For example, a computer that is running Microsoft Windows 2000 Professional or Microsoft Windows XP Professional does not have the File and Printer Sharing for Microsoft Networks check box selected in the network connection properties.
  • The client computer that is listed in the Dispatch.log file error message is not running the Remote Procedure Call service.
  • The client computer that is listed in the Dispatch.log file error message does not have the correct DNS service settings.
  • The DNS service settings are not correct on the computer that is running Windows Small Business Server 2003 or on the computer that is running Small Business Server 2000.
The "Agent" is the Active Directory Migration Tool component that configures the client computer to be a member of the destination domain. The Agent tries to connect to the Admin$ share on the client computer to make this change. In this case, the Agent cannot connect to the client computer's Admin$ share because of network problems. For example, the client computer that the Agent tries to configure may not be running the Remote Procedure Call service or the File and Printer Sharing service. Or ,a DNS service problem may prevent the Agent from resolving the client computer's IP address.

RESOLUTION

To resolve this behavior, you must first determine the cause of the error. To determine the cause of the error and then resolve the behavior, follow these steps:
  1. On the computer that is running Small Business Server 2000, make sure that the DHCP Server service is disabled and stopped. To do this, follow these steps:
    1. Click Start, point to Administrative Tools, and then click Services.
    2. Under Name, click DHCP Server, and then look under Startup Type to see if the DHCP Server service is disabled.
    3. If the DHCP Server service is not disabled, right-click DHCP Server, and then click Properties. In the Startup type list, click Disabled.
    4. If the DHCP Service is not stopped, click Stop in the Service Status area, and then click OK.
  2. On the Small Business Server 2000 server, make sure that the only forwarder that is listed in DNS is the internal IP address of the computer that is running Windows Small Business Server 2003. To do this, follow these steps:
    1. Click Start, point to Administrative Tools, and then click DNS.
    2. Right-click Small_Business_Server_2000_Server_Name, and then click Properties.
    3. Click the Forwarders tab. The only IP address that is listed in the Selected domain's forwarder IP address list area must be the internal IP address of the computer that is running Windows Small Business Server 2003.
  3. On the computer that is running Small Business Server 2000, make sure that the Remote Procedure Call (RPC) service is running. To do this, follow these steps:
    1. Click Start, point to Administrative Tools, and then click Services.
    2. Under Name, click Remote Procedure Call (RPC).
    3. Look under Status to determine whether the Remote Procedure Call service is started.
    4. If the Remote Procedure Call service is not started, right-click Remote Procedure Call (RPC), and then click Start.
  4. On the computer that is running Windows Small Business Server 2003, make sure that the DHCP Server service is started. To do this, follow these steps:
    1. Click Start, point to Administrative Tools, and then click Services.
    2. In the Services list, click DHCP Server, and then look under Status to determine whether the DHCP Server service is started.
    3. If the DHCP Server service is stopped, right-click DHCP Server, and then click Start.
  5. On the computer that is running Windows Small Business Server 2003, make sure that the Remote Procedure Call (RPC) service is set to automatic and that the service is started. To do this, follow these steps:
    1. Click Start, point to Administrative Tools, and then click Services.
    2. Under Name, click Remote Procedure Call (RPC).
    3. Look under Startup Type to determine whether the Remote Procedure Call service is set to automatic, and then look under Status to determine whether the Remote Procedure Call service is started.
    4. If the Remote Procedure Call service is not set to automatic, right-click Remote Procedure Call (RPC), and then click Properties.
    5. On the General tab, click Automatic in the Startup Type list, and then click Apply.
    6. If the Remote Procedure Call service is not started, click Start in the Service Status area, and then click OK.
  6. On the computer that is running Windows Small Business Server 2003, make sure that the Remote Procedure Call Locator service is set to manual and that the service is stopped. To do this, follow these steps:
    1. Click Start, point to Administrative Tools, and then click Services.
    2. Under Name, click Remote Procedure Call (RPC) Locator.
    3. Look under Startup Type to determine whether the Remote Procedure Call Locator service is set to manual, and then look under Status to determine whether the Remote Procedure Call Locator service is stopped.
    4. If the Remote Procedure Call Locator service is not set to manual, right-click Remote Procedure Call (RPC) Locator, and then click Properties.
    5. On the General tab, click Manual in the Startup Type list, and then click Apply.
    6. If the Remote Procedure Call Locator Service is not stopped, click Stop in the Service Status area, and then click OK.
  7. On the computer that is running Windows Small Business Server 2003, make sure that the only IP address that is listed on the Forwarders tab in DNS is the internal IP address of the computer that is running Small Business Server 2000.
    1. Click Start, point to Administrative Tools, and then click DNS.
    2. Right-click Small_Business_Server_2003_Server_Name, and then click Properties.
    3. Click the Forwarders tab. The only IP address that is listed in the Selected domain's forwarder IP address list area must be the internal IP address of the computer that is running Windows Small Business Server 2003.
  8. On the computer that is running Windows Small Business Server 2003, determine whether the client computers have host (A) records in DNS. If not, manually create host (A) records, and then create the associated PTR records. To do this, follow these steps:
    1. Click Start, point to Administrative Tools, and then click DNS.
    2. Expand Small_Business_Server_2003_Server_Name, and then expand Forward Lookup Zones.
    3. In Forward Lookup Zones, determine whether a Host (A) record exists for each client computer. If all client computers have Host (A) records, go to step 9.
    4. If you must add host (A) records for a client computer, right-click Your_Server_Domain, and then click New Host (A).
    5. In the Name box, type the name of the client computer that requires a host (A) record.
    6. In the IP address box, type the IP address of the client computer that requires a host (A) record.
    7. Click to select the Create associated pointer (PTR) record check box, and then click Add Host.
  9. On the client computers, make sure that the Remote Procedure Call (RPC) service is running. To do this, follow these steps.

    Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
    1. Click Start, and then click Control Panel.
    2. Click Switch to Classic View.
    3. Double-click Administrative Tools, and then double-click Services.
    4. Under Name, click Remote Procedure Call (RPC).
    5. Under Status, make sure that the Remote Procedure Call service is started. If the service is not started, right-click Remote Procedure Call (RPC), and then click Start.
  10. On the client computers, make sure that file and printing sharing is turned on. To turn on file and printing sharing on the client computers, follow these steps.
    1. On each client computer, click Start, and then click Control Panel.
    2. Click Switch to Classic View.
    3. Double-click Network Connections.
    4. Right-click your connection to the local network, and then click Properties.
    5. Click the General tab, and then click to select File and Printer Sharing for Microsoft Networks in the This connection uses the following items list.
    6. Click OK.
  11. Determine whether the IPC$ and Admin$ shares exist on the client computers. To do this, follow these steps:
    1. On each client computer, click Start, click Run, type CMD, and then click OK.
    2. At the command prompt, type Net Share, and then press ENTER.
    3. You see a list of all the shares on your local computer. Make sure that IPC$ and Admin$ are in the list.
    4. If IPC$ and Admin$ are not in the list of shares, restart the Server service to re-create these shares. To do this, open Services, right-click Server, and then click Restart.
  12. Renew the IP address on the client computers. To do this, follow these steps.
    1. On each client computer, click Start, click Run, type CMD, and then click OK.
    2. At the command prompt, type the following two commands, and then press ENTER after each command:

      IPConfig /release
      IPConfig /renew
    3. Make sure that the IP address that is assigned to the client computer is in the same range as the address that is assigned to the computer that is running Windows Small Business Server 2003.
  13. On the computer that is running Windows Small Business Server 2003, test some client computers to make sure that the computers are listening for RPC traffic on Port 135. To do this, follow these steps:
    1. Click Start, click Run, type CMD, and then click OK.
    2. At the command prompt, type telnet IP_Address_of_the_Client _Computer 135, and then press ENTER. If the client computer is listening for RPC traffic on Port 135, you will see a blinking pointer.
  14. On the computer that is running Windows Small Business Server 2003, test some client computers to make sure the admin shares are available. To do this, follow these steps:
    1. Click Start, click Run, type CMD, and then click OK.
    2. At the command prompt, type net use \\Client_Computer_Name\admin$, and then press ENTER. If the admin shares are available on the client computer, you will receive a message that says that the command completed successfully.

Modification Type:MajorLast Reviewed:9/1/2004
Keywords:kbwinservds kbActiveDirectory kbprb KB837366 kbAudITPRO