Error message when you try to open a file on a Windows XP-based client and the file is cached by another user (837131)



The information in this article applies to:

  • Microsoft Windows XP 64-Bit Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

Consider this scenario. A program exists on an offline share of a computer that is running Microsoft Windows Server 2003. The share is optimized for performance. Network clients are running Microsoft Windows XP. When the second Windows XP-based client tries to access the program on the offline share, the clients may receive an error message that is similar to the following:
Program_Name - application. Error The application failed to initialize properly (0xc0000022). Click on OK to terminate the application. The file is locked or you do not have permissions to the file.

CAUSE

When you open a file that is in the cache, but the file is cached by another user, access is denied because you do not have permissions to the cached data. Therefore, the open command fails.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   25-Mar-2004  23:03  5.1.2600.1367     236,544  Cscdll.dll      
   25-Mar-2004  21:50  5.1.2600.1367   1,276,416  Mrxsmb.sys
   25-Mar-2004  21:50  5.1.2600.1367     495,616  Rdbss.sys
   25-Mar-2004  23:00  5.1.2600.1367      92,160  Wcscdll.dll      

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbBug kbfix kbQFE KB837131 kbAudEndUser