Performance Monitor stops responding on Windows Server 2003-based computers that have more than 40 logical disks (837126)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition

SYMPTOMS

When you try to gather performance data on a computer that is running Microsoft Windows Server 2003, you may experience increased memory consumption. The disk performance counters may show consumption of as much as 2 gigabytes (GB) of memory, and the performance monitoring program may stop responding. Also, some performance objects, such as the Logical Disk object and the Physical Disk object, may disappear from the performance counter monitor.

CAUSE

This problem may occur on computers that have 40 or more logical disks.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

IA-64
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Feb-2004  00:59  5.2.3790.132       55,808  Perfdisk.dll     IA-64
   24-Feb-2004  01:00  5.2.3790.132       25,600  Wperfdisk.dll    x86
   20-Jan-2004  01:53                        271  Branches.inf
   24-Feb-2004  01:06                     10,119  Kb837126.cat
   24-Feb-2004  01:02                        354  Updatebr.inf
   24-Feb-2004  01:02                      6,540  Update_rtmqfe.inf
x86
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Feb-2004  01:00  5.2.3790.132       25,600  Perfdisk.dll     
   20-Jan-2004  01:54                        271  Branches.inf
   24-Feb-2004  01:06                      9,766  Kb837126.cat
   24-Feb-2004  01:01                        354  Updatebr.inf
   24-Feb-2004  01:01                      6,265  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbWinServ2003preSP1fix kbMemory kbPerformance kbinterop kbMiscTools kbQFE kbfix kbBug KB837126 kbAudITPRO